Fail to connect to admin GUI

I’m terribly embarrassed, but I need help with what should be a really basic problem. Troubleshooting GUI connectivity!

I have a long and smoothly running FPBX installation with the most recent version (as of 3 months ago), however currently I cannot connect to the admin GUI from my office PC. My browser simply reports ‘connection refused’. My SIP phones are all connected and operating properly, the only problem is access to the GUI. I have a second office location and the phones are working properly there, but VPN’ing into that network and attempting the admin GUI gives me the same connection refused.

My first thought was that I have been jailed in fail2ban for some reason (undoubtedly deserved). I have access to the CLI from the console, so I checked the jails for my IP and ran an ‘unbanip’ for all jails (thank you Dicko and LGaetz) for good measure. This reported that my IP was not present in any of the jails.

My next thought was that since I had a network-wide reboot about a month ago, I probably lost my previous external dynamic IP address and my new one is not among the whitelisted/trusted networks for the GUI. I looked into inserting my IP into the whitelist using ‘fwconsole firewall list trusted’ and then ‘fwconsole firewall trust [myIP]’. But I had the nagging feeling that this was inserting something into the FPBX responsive firewall which I don’t think I have enabled. It didn’t help.

My next thought was that I should get down into the web access and error logs and see what is really going wrong. I went down into the file structure and looked at (tail’d) /var/log/httpd/ access and error.log, but they were empty. I backed up and went into the asterisk directory and checked freepbx.log and fail2ban.log and full.log. However, I could not find any connectivity issues. It was at this point that I admitted to myself that I am on the wrong road and I need help.

Would you kindly help me find the tools and strategies to troubleshoot a GUI connectivity problem?

Humbly yours,

Have you just tried restarting the FreePBX to see if that might clear whatever the problem is?

What is providing your web service?

lsof -i:80

Thanks dicko and Dobrosavljevic! Aaarghhh!!! I didn’t even think to check if anything was actually running on port 80. This machine just always works!! But guess what…

[root@pbx ~]# lsof -i:80
[root@pbx ~]#

Then, of course, checking the services:
● httpd.service loaded failed failed The Apache HTTP Server

So, naturally…
[root@pbx ~]#service httpd start

And, all is well. That certainly explains why the logs were empty.

I am so sorry to have bothered you. I truly appreciate your putting me back on the right path.

I will do a backup later tonight, then check for module and core updates and do a reboot.

So embarrassed!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.