Extremely long TFTP boot issues with Polycom devices

We have a local TFTP server run with Pumpkin behind a router with TCP/UDP 69 port forwarded. In the directory we have configuration files for our company as well as bootrom and application software. 95% of our users can have their phones pointed to our public IP and via the server type set to Trivial FTP and then the public ip for server address. But 5% of users are having issues where just grabbing one small configuration files such as .cfg is taking forever. The phone ends up on a Provisioning or updating configuration screen forever.

I cannot seem to see a pattern for the few where this doesnt work. I am thinking perhaps ISP or perhaps their router. Has anyone come across this issue? Again, it does work and it works for most, but every once in a while we run into this issue. I dont believe its on our side since we also tried setting up a TFTP using other cloud hosting services with different bootrom and application software and yet still the same results where it just gets stuck

Any help would be super appreciated

Thank you

Why not use FTP instead? What version firmware and what handsets are you using?

in my experience Polycoms are slow booters.

  • Assuming all models are the same
  • Assuming all models are pulling down the same basic configuration
  • Assuming all phones are on the same firmware
    If any of the assumptions are incorrect make them correct

If this doesn’t fix your issue…

Then look at the network node… Try physically moving a known bad phone to a known good location.

If that fixes it you have your answer…

If not then do a factory reset.

If that fixes it you have your answer…

If none of these fix your issue it may be time to contact Polycom.

Document Document Document Document Document Document Document Document Document
Hello tech support:

  • I have X phones
  • They are all X Model
  • They are all running X firmware.
  • X Phones work fine
  • X Phones do not
  • I Swapped a known bad with a known good without change
  • I factory reset X phones with no change

Give details of what you did and it will make the process pretty painless.

Current Polycom software is not slow to boot. I get about 7 seconds on my 450 running 4.06, which is why I asked OP for details. Those awful old 320s and the like were definitely painful on boot though!