Externip= works

Using broadvox and a few other registered sip providers I set the externip= to the actual external ip address of the asterisk server and I receive one way audio. When I change it to or take out the externip entry then audio works both ways. Looking at several older servers i’ve setup there is no externip and they are working properly.

They all have nat=yes and are behind firewalls.

Why is this working without externip set correctly? Everything I know says this should not work.


Thanks, that would explain it.

if the provider is proxy-ing all the media on their SIP server and they are ignoring the SIP header information (very similar to what nat=yes does for you with remote phones), then it can work.

The down side of proxying the media is they are probably inherently lowering your call quality. Once they receive the media stream, they are going to have to send it to a media server usually which means there is added latency since it has to relay through their system.

This may not always be the case but often is, but it gets around the issues of forwarding ports and other settings.

When you provided the proper IP address they probably started flowing the media directly from the server but if you didn’t have ports forward properly at the firewall, you ended up with one-way audio.

Using 2.5 and 2.8 of freepbx and 1.4 and 1.6 of asterisk