External Polycom using internal IP on Freepbx

This is an issue that has me baffled for the past week.

I have an External Polycom (VVX 410), that is registering with asterisk, but the contact info shows my local IP, nit the public one, so when RTP traffic comes my way, I never get it - it’s sent to 192.168.x.x instead of 50.200.x.x

I am able to confirm that SIP traffic works. I dial 411 and get the logs show a response, my phone’s call length timer activates and all is well, EXPECT no sound… and it’s two way.

I’ve added a line to a different PBX, and all is well. I’ve configured a Softphone from the same location (therfore, same Firewall, Public IP, etc…). The Softphone works.

It would look like I haven’t told the Polycom to NAT to this particular PBX, but there is no NAT checkbox on the Polycom, and changing only the UserID,Password, and Server IP I can sucessfully use it on a different PBX.

There are no SIP ALG in the path.

I’ve tried all i can think of, but no sucess.

Any ideas?


If you edit the extension what is the NAT setting (advanced tab).

It’s set to Yes (Force rport, comedia). That was the first thing I checked.

1 Like