External IP applied, but server is not pinging/replying from the outside

I’ve set my VOIP provider’s dedicated IP to my server through the UI. For some reason, it does not reply to ping from the outside. I’ve set the IP via ‘asterisk sip settings > External IP.’ I’ve left the ‘Local Networks’ column with 172.20.xxx.xxx/, which is for my LAN segment.

FYI… I’m currently using a Trixbox Pro server, but plan to transition to my FreePBX server. The Trixbox replies to ping form the outside utilizing the external IP address. Before testing, the Trixbox is disconnected to avoid any conflicts.

Setting the external IP as you have done does not expose the server to the Internet. Do you only have one external (public) IP on yor router. If yes you will need to port forward from the router to the FreePBX server to get external access to your server. I would not forward pings to your FreePBX server.

Hello Alan,

My current PBX (Trixbox) is utilizing the external IP, and I can ping it from the outside. Technically, isn’t the router already configured for this IP to be exposed? I’ve configured the external IP onto the FreePBX server, and disconnected my Trixbox. But, I do not receive a reply. What more needs to be done?

I was told that I need to configure the external IP cia CLI. Is there any truth to this?

The external IP setting you refer to is for NAT translation of audio. If you are running the server behind a firewall the firewall NAT’s from your public IP to the internal IP of your new server.

Besides the GUI, can the external ip be configured through the cli? If so, ‘system-network-config’ does not have this option. What are the correct commands?

It’s system-config-network tab key is your friend, type system-config and then hit tab, watch what happens, Linux presents a lists of all commands starting with that expression.

We have a conceptual issue with regard to what you are asking. The interface IP address is configured on the server (not via the GUI, use system-config-network). You keep saying “outside” IP. Unless the server is connected to a public interface the outside IP address is not set on the server but in your router.

Can you tell us what you are trying to accomplish? Are you trying to get remote phones to register?

Hello Skyking,

I want to get this FreePBX working with my VOIP provider. Here is the breakdown below:

I currently have a Trixbox (which we plan to remove) in production. This Trixbox has our dedicated external IP (65.xxx.xxx.xxx) attached to it. I can ping the Trixbox from the outside (my house, library, etc.).

I’ve attached this same IP to our newly built FreePBX server (and unplugged the Trixbox), but it does not reply to ping, as the Trixbox does. I have everything configured (IVR’s, extensions, trunks, outbound/inbound routes, etc.) within FreePBX, but I just can’t make or receive any calls. I’m assuming this has to be with the connectivity issue.

My voip provider does not require to authenticate via registration string nor secret. My current box is an unregistered box.

It’s dangerous to put a public IP on your phone system. Why would you want to do that? Unless you are a security guru you will have people making calls on your server in no time.

Anyway, you have to set the IP on the network adapter. Did you run the setup-config-network script?

Post the output of the ifconfig command, it will tell you the IP assigned to your network card(s).


I think there is some confusion here, and I believe it’s on my part. See below…

My FreePBX server is configured with an internal IP of 172.xxx.xxx.xxx (eth0), which I’ve configured using ‘setup-config-network.’ I’ve added the external IP 65.xxx.xxx.xxx via the GUI as instructed. From the outside world, I cannot ping the external IP when attached to my FreePBX server. With the same config applied to my current Trixbox PBX, I can ping the box with no issues.

We are dealing with two different boxes, and two different interfaces, which both utilize Asterisk.

Is there any additional info you need to help resolve this? Thanks.

I don’t understand what adding the IP via the GUI is going to do.

How is the public address going to get to the server? Is it NAT’d in your router to the 172 address?

What are you trying to do? I asked this before and it is critical. Is the goal to register extensions from the Internet?

You also said you can’t ping the IP, where are you trying to ping from?

Simply make outbound calls, as well as receive them from the outside world. I think you just solved my problem. I believe my current PBX’s IP (which is different from the FreePBX’s) is tied to my external IP (NAT’d as you mentioned). The next step is to disconnect my current PBX (during non-business hours of course), configure the FreePBX box with my current server’s IP, and troubleshoot from there. Thanks for your input. I’ll let you know how it works out.

P.S. No phones need to be registered from the internet, just internal SIP devices.


Come to find out, my external ip is NAT’d to my internal ip as you mentioned. I applied that internal ip to my FreePBX box, but I cannot get into the GUI. I’m thinking caching issue at the server itself. I’ve tried multiple browsers, and timing out happens in all of them. Any ideas?

No, something is blocking port 80, it’s not a cache issue. Can you SSH to it?

I also strongly suggest you do not put the web interface on the Internet for security concerns. I would use a VPN if you need to administer remotely.

I didn’t try to SSH into it using the final IP attached (172.xxx.xxx.50, which is NAT’d), but it works (GUI and SSH) when I placed it back onto its temporary IP (172.xxx.xxx.49, non-NAT’d).

Just to be clear, see below:

Current PBX (which will be replaced with the FreePBX device)

  • Trixbox Pro
  • Internal IP: 172.xxx.xxx.50
  • External IP: 65.xxx.xxx.xxx
  • External is NAT’d to Internal
  • GUI and SSH works

Replacement PBX

  • FreePBX
  • Internal IP: 172.xxx.xxx.49 (non-NAT’d)
  • GUI and SSH works

It was found that the IP was trying to reach index.cgi (current pbx’s start page), instead of config.php. Outbound calls work, but inbound doesn’t. Must be the trunk’s config itself. Authentication is failing at some point.

So glad I spent all this time trying to help you.

Your welcome :frowning:

Thanks Skyking, you’ve been extremely helpful. Your multiple responses assisted in getting this box working properly. Thanks again!

I was not soliciting gratitude as much as I was being a smart ass.

You truly don’t realize that the purpose of a support forum is not to teach basic networking and ask 20 questions to get you to overcome your lack of planning in your installation. The problem turned out to be non-FreePBX related.

The other insult is you are probably getting paid to do this work.

People wonder why I occasionally get a bad attitude.

I am glad you got it working but more importantly I hope you learned something about networks, planning and project management in general.