Extensions not working...pretty much nothing working actually!


I’m really struggling to figure out what is going on here!

I originally set up Asterisk (via Trixbox) on a virtual machine. All was looking good, but voicemail sounded really weird, which I put down to a timing issue I read about with VirtualBox virtual machines. So, I decided to take the plunge and install Asterisk on my existing Ubuntu PC.

What a nightmare!

I managed to get it up and running, and FreePBX as well. However, for some reason that I cannot figure out, I can’t get the extensions to call each other (let alone ring outside!) Nothing seems to work. They’re listed as OK from “sip show peers”, and they can dial voicemail fine. But whenever they call each other, all I get is the “Your call cannot be completed as dialed, please check the number and dial again.”

The only hint I have is when I dial *65, the recording say “your extension number is” and then nothing. Would that be related?

Any help would be greatly appreciated!

Start with an ISO Like AsteriskNow or PiaF…

Thanks cosmicwombat. I did start with Trixbox running in a VM, and it all worked fine. Which is why it’s weird that it’s not working now in this install in Ubuntu! Someone recommended (on another forum) I look at contexts? How are these handled in FreePBX, do you know?

thecrane, in other words… use the distro on the hardware instance. Stick with what worked for you, trixbox uses CentOS as do the others.

Ubuntu is a fine platform, but considering the major distros use CentOS and therefor most of the people in these forums are using CentOS based systems… You are going to get a lot more answers to your questions…

It is really hard to say what you forgot to do or install, setup and configure. Probably more than you know. Hence the issues.

Not really that weird. What you are saying is a lot like “I went to the car dealer and got a car and drove it around, it worked well for me. Then next day UPS delivered that car-in-the-box I ordered and even though I have never built a car… I went ahead and did my best, but it won’t start and drive… It should have worked… the already assembled one worked!”

There is just no logic in that.

Fair call cosmicwombat. :slight_smile: My problem is that the server running Ubuntu is also my DNS and DHCP, and I don’t know enough about CentOS to get the same config up and running there.

However, a bit more information has come to light.

Through some frantic reading of other sites, and the Asterisk online book, I’ve experimentally added some custom callplan stuff to extensions_custom.conf.

The two extensions (210 and 211) can now call each other with these lines added:

exten => 211,1,Dial(SIP/211)
exten => 210,1,Dial(SIP/210)

But why do I need to add these manually? Surely they should just be added by FreePBX?


you are digging yourself a deep hole really fast trying to add fundamental dialplan to extensions_custom.conf, in addition to the fact that it is wrong.

FreePBX configures everything that you need. If you are having problems, don’t start writing dialplan to fix it…

For starters, make sure apache is running as user asterisk, as should asterisk. Then do an ampotal stop / amportal start. Then press the orange “Apply Configuration Changes” bar in FreePBX. (Go edit something if you don’t see the orange bar so it will come up). Once you have done all of the above, you might start to work.

Good luck and again. don’t second guess FreePBX, just work on getting your install in order…now off to Maui (well tomorrow anyhow).

p.s. check the notification panel for errors also, you may have to delete some files like extensions.conf prior to pressing that orange bar…

thecrane, what I am suggesting is that you do not run your phone system on your DHCP/DNS box. That way you are not messing with that service while you are trying to learn a new one.

An old P4 w/1GB RAM will run a 10 extension system without breaking a sweat.

btw, did you look through http://www.freepbx.org/support/documentation/installation on the debian and ubuntu bits?

I have to echo what others have been saying: use an Asterisk distro like PiaF (my choice) or AsteriskNow - there’s no use in re-inventing the wheel. They both utilize FreePBX and have excellent support forums where the users know exactly how it is configured.

In your case, you have an oddball setup that is extremely difficult for someone to troubleshoot. If you have a mainline distribution, I could turn on my PiaF test box and actually look and compare.

Ubuntu is a pain in the butt for anything except a desktop machine. Even then during the last three successive updates, I’ve lost support for my mouse driver, sound card and video card. I had to give up and physically replace them all! I still have some screwball sound card issues with Pulse audio not wanting to talk to Alsa. I used to like Ubuntu but the dropping of support for previous devices is atrocious!

PiaF has support for both DHCP and DNS among many other things in addition to Asterisk.