Extensions always got busy line if another extension is in call

Hello I’m new in FreePBX
I’m using FreePBX

I have 3 trunks (last 4 digits are: 2976, 0702, 0704) and 6 extensions (214,215,216,221,222,223).
I want that any extension to be able to use any available trunks for outbound calls.
The calls work perfectly on each extensions.
I set “Continue if Busy” on all trunks and i see the “In use by 3 routes” message on the trunk’s page.
In the outbound routes, I set the other trunks in the “Trunk sequence for matched routes” one after the other. (is it need or not?)

The orders are as follows in the outbound routes:
1.trunk: 2976 - 2976,0702,0703
2.trunk: 0702 - 0702,0703,2976
3.trunk: 0704 - 0704,0702,2976

I set the callerID in the Outbound Routes/Dial Patterns to 21[4-6] and 22[1-3]. (which extension has rights to which trunk. isn’t it?)


If one extension calls, I get an “All circuits are busy now please try again later” message on the other extensions.
The problem is each extension first tries to call the first trunk set as the first in the outbound routes (2976).
Why my extension not jump to the next free trunk?

I think the Dial Patterns is the main problem but I don’t know how to set it to be good.

Should I attach any logs? If yes, which one?

So sorry if my english is full with error…
Thanks if you help :wink:

Providing Great Debug - Support Services - Documentation (freepbx.org)

This is the log while I want to call the +36XXXXXX517 number.
My trunk’s numbers are:

I tried to copy it here, but it’s too long so I linked it.

any help is greatly appreciated :slightly_smiling_face:


Hangup cause 21 just says that the call was rejected by the 0704 and 0702 trunks. For more details, at the Asterisk command prompt (not a shell prompt), type
pjsip set logger on
make another failing test, and paste a new log, which will now include SIP traces.

Thank for your answer!
I maked a call from extension:215 and then 216.
I called the XXXX517 number

Sorry, the link shows
Error, this is a private paste or is pending moderation. If this paste belongs to you, please login to Pastebin to view it.

Sorry still in pending…
I uploaded the txt file to the cloud.

On the call via the second trunk, sip.ephone.hu rejected the call with
SIP/2.0 403 Invalid From username

From: <sip:XXXXX[email protected]>;tag=3327881d-ca19-4d48-a179-059ff835a225

If this came from the From User setting in the trunk, you need to set it to the correct value for each trunk.
If this is a caller ID you are trying to send, it appears that ephone doesn’t support sending a caller ID that doesn’t correspond to the number on the trunk, so you need to set From User or Force Trunk CID appropriately.

1 Like

I will try it on monday :wink:

Force Trunk CID seems to have solved the problem.
Now I can call from the next free trunk if the first is busy.
Very very thanks for you help :wink:

If you come to Hungary, you are my guest for a couple of beers :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.