Extension to ivr?

I have an inbound route setup as the same number as the misc application I have set and I would like to have it go straight to an ivr.

When I call it via sipbroker.com fwd as a sip uri it doesnt work. I call any other extension via sip uri it works fine.

Would I need to set it up as an actual extension and modify the settings?
Thank you


I am having an odd problem with 2 ivrs playing at the same time… I want an ext to go to ivr

include => ext-local-custom
exten => 1,1,Goto(ivr-2|s|1)
exten => 2,1,Goto(ivr-13|s|1) So the ext picks up but so does “im sorry that is not a valid extension”

http://clip.drlinky.com/20 Is some of the logs> Iam calling from fwd.

Thank you for any info.

if you are implying you are editing extensions_additional.conf, don’t do that - it will get overwritten.

yes I know… however do you have a solution for this problem?

thank you

I don’t understand your problem. If you want an inbound did to hit an ivr, then you use inbound routing and point at the ivr as its destination. If you have an ivr that you want internal extensions to call, then you use miscapp (as you pointed out) to create a ‘feature code’ that you can use to call that ivr.


Well what I should have said is that I defined the extension here as well with the same results

exten => 1,1,Goto(ivr-2|s|1)
exten => 2,1,Goto(ivr-13|s|1)

It works but it also plays “this is an invalid extension” as the same time the other ivr is playing. Does anyone else find this odd?

I commented out the changes I made above, reloaded, verified that they didnt work… then I made the inbound ivr

exten => 2,1,Goto(ivr-13,s,1)

but when I try to call [email protected] via a sip call using fwd it doesn’t even hit the server at all.

That is why I didn’t use inbound routes.

I guess another question is, when an call is sent to the server to a non existent extension, does it even register in asterisk?

it sounds like you are trying to ‘go around the system’ without enough understanding of how it works, and without needing to.

If you have anonymous sip enabled (needed unless you have a trunk letting the calls in) and you have an inbound route for a did, then it will come in. Any sip call that hits the server will have some info in the log - typically it will just be quickly killed unless you enable anonymous calls and send them somewhere.

Nope everything was fine after all. I just didnt try enough clients. For some reason FreeWorldDialup client was passing an extra 7 along. use anything else and it was fine. I should have tried this first, but with the negative atmosphere surrounding anything to do with “custom” around here I didnt.

Who uses free world dialup anyway?


I’m having the same ‘issue’ as is being discussed in this ticket. Using freepbx 2.11. It seems that misc app isn’t there anymore and I just can’t find out how to have an extension be forwarded to an IVR.

How to accomplish this in freepbx 2.11?