Extension Rings only from DID, not internal extension

If I call my extension from another extension on my asterisk server, the call goes straight to voicemail:

Jul 27 01:25:49] VERBOSE[13549] logger.c: -- Executing [[email protected]:7] Dial("SIP/marc10-b73c8c50", "SIP/200|22|rM(auto-blkvm)") in new stack [Jul 27 01:25:49] WARNING[13549] rtp.c: Unable to set TOS to 184 [Jul 27 01:25:49] VERBOSE[13549] logger.c: -- Called 200 [Jul 27 01:25:49] VERBOSE[28246] logger.c: -- Got SIP response 486 "Busy Here" back from xx.xxx.xxx.xxx [Jul 27 01:25:49] VERBOSE[13549] logger.c: -- SIP/200-08b1ba50 is busy

However if I call it via a DID, it rings:

[Jul 27 01:29:22] VERBOSE[15902] logger.c: -- Executing [[email protected]:7] Dial("SIP/marc10-b7377940", "SIP/200|22|rM(auto-blkvm)") in new stack [Jul 27 01:29:22] WARNING[15902] rtp.c: Unable to set TOS to 184 [Jul 27 01:29:22] VERBOSE[15902] logger.c: -- Called 200 [Jul 27 01:29:22] VERBOSE[15902] logger.c: -- SIP/200-08b1ba50 is ringing

Any ideas why? The extension is using a SPA2102.

And a bonus question. Should the warning ‘Unable to set TOS to 184’ concern me?

I tried using a SIP client other than my Linksys SPA2102 and the call rang. That leads me to believe that the ATA is causing the call to go straight to voicemail.

I grabbed the logs from my Linksys. I have no idea what I am looking for so I thought I would post them here to see if anyone can make sense of them.

The call that gets sent to straight to voicemail looks like this:

SIP/2.0 501 Method Not Implemented

Via: SIP/2.0/UDP xx.xx.xx.xxx:5060;branch=z9hG4bK-69483c03;received=xx.xx.xx.xxx:;rport=5060

From: Marc sip:[email protected];tag=b878d1e0429f8befo0

To: Marc sip:[email protected];tag=as10060bd4

Call-ID: [email protected]

CSeq: 9 PING

User-Agent: Asterisk PBX

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY

Supported: replaces

Content-Length: 0

[0]<<xx.xx.xx.xx:5060(432)
[0]<<xx.xx.xx.xx:5060(432)

INVITE sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP xx.xx.xx.xx:5060;branch=z9hG4bK163314f5;rport

From: “XXXXXXXX” sip:[email protected];tag=as2e39cb53

To: sip:[email protected]:5060

Contact: sip:[email protected]

Call-ID: [email protected]>

CSeq: 102 INVITE

User-Agent: Asterisk PBX

Max-Forwards: 70

Date: Sun, 27 Jul 2008 16:39:00 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY

Supported: replaces

Content-Type: application/sdp

Content-Length: 262

v=0

o=root 32080 32080 IN IP4 xx.xx.xx.xx

s=session

c=IN IP4 xx.xx.xx.xx

t=0 0

m=audio 10258 RTP/AVP 0 8 101

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=silenceSupp:off - - - -

a=ptime:20

a=sendrecv

[0]->xx.xx.xx.xx:5060(313)
[0]->xx.xx.xx.xx:5060(313)
SIP/2.0 100 Trying

To: sip:[email protected]:5060

From: “XXXXXXXXX” sip:[email protected];tag=as2e39cb53

Call-ID: [email protected]

CSeq: 102 INVITE

Via: SIP/2.0/UDP xx.xx.xx.xx:5060;branch=z9hG4bK163314f5;rport=5060

Server: Linksys/SPA2102-3.3.6

Content-Length: 0

[0]->xx.xx.xx.xx:5060(339)
[0]->xx.xx.xx.xx:5060(339)
SIP/2.0 486 Busy Here

To: sip:[email protected]:5060;tag=8c50e9744a82396bi0

From: “XXXXXXXX” sip:[email protected];tag=as2e39cb53

Call-ID: [email protected]

CSeq: 102 INVITE

Via: SIP/2.0/UDP xx.xx.xx.xx:5060;branch=z9hG4bK163314f5;rport=5060

Server: Linksys/SPA2102-3.3.6

Content-Length: 0

I know this may be obvious, but are you sure you selected the correct destination in inbound routes? Is it possible you have selection that forces a call directly to voicemail?

I’ve done this once or twice.

Bill/w5waf

hey bill.

thanks for the suggestion. but I tried using two different sip clients. one went to vm and one didn’t - so I got to believe it is being caused by the client.

In case anyone is following along – I did a factory reset on the Sipura SPA2102 (the ATA the was sending the internal calls straight to voicemail) and now calls come through.

It must have been a setting on the SPA2102, but I’m not sure which one.