Extension rings but when they pick up, it is a dial tone

I have a user on my system where when I call them it rings. Even after they pick up, it continue rning for me, and they get a dial tone.

They can make outgoing calls with no problem.

Incomign calls have never worked.

We are using Cisco STA122 and STA112 ATA boxes.

We programmed all the ATA boxes the same way including the one that I used to call the other one. WE did nto touch any of the advanced configureationoptions. We entered in only 3 pieces of information:

extension #
domain where the server is

Any ideas as to why the extension might not be working.

I will say as wel that this ATA box has 2 extensions that are configured. They are configured the same way and they both do not work.

We even reset the ATA box and reprogrammed it. Same problem.

Thanks for ideas.


Maybe your hardware is broken.

I might think that one, but 2 brand new ATA boxes? This is why I tested a second one, to dismiss this idea.

I will be trying one of them in another house in a couple of days. If they work, then it is the home set up. If it does not work, then, it might be the box.

Any ideas?


Almost certainly an incorrect setup of your intermediary routers, as always disable any SIP “Helper” functions on them (by whatever name the are called) and rely on asterisk’s built-in natting translations.


I did test the box elsewhere, and it works just fine at another location. The box is definitely not broken.

On their router, there is no SIP helper function.

As for the ports, I have them set up on the rtouer for the server at:
5010-5061 - UDP
10000-20000 - UDP

But, on the users end, I did not have the router set for any ports.
I just tried adding port forwarding on the users router, and the
problem persists.

I set theirs up as:
5060-5061 - UDP
10000-20000 - UDP

I have 2 other users who do not have any thing set up on their routers, and they work fine.

I did bring the ATA box to another location, it makes and receives calls just fine.

So, it is a port/router/nat issue.

An ideas?



It’s obviously a port/router/nat/provider issue.

I wanted to stop back and let everyone know what it was.

We were using a DLInk router. We swapped it otu for a Cisco router.

All works now.

Thanks for all your ideas and help. WE were abel to narrow it down and got the router as the issue!