Extension not found

I am an Asterisk and FreePBX beginner and it appears the simplest things don’t work for me. I have FreePBX 2.4.0 and Asterisk 1.6.0-beta9 (and I have also tried 1.4.21 and 1.4.17), all on Ubuntu 8.04.

I have created two SIP extensions and one SIP trunk. I have installed two SIP clients: ExpressTalk and X-Lite on a Windows PC. I have set them up and successfully connected to Asterisk which I confirmed by looking at FreePBX’s system status page as well by running “sip show peers” in Asterisk CLI.

The SIP trunk is supposed to connect a remote Linksys SPA-3102 to Asterisk in order to provide means for inbound and outbound PSTN calls. This device also registers successfully with Asterisk.

Other than this nothing works. :frowning:

When I try to call the other extension from either of the two SIP clients, I get “Not found” error. If I try to call *xy, this throws the same error. Basically, anything I type in either of SIP clients ends up with “Not found” error.

I wasn’t too optimistic about getting Linksys to work straight away but setting up two simple extensions seemed like a straightforward task.

Inspecting Asterisk’s logs reveals warnings as follows:
netsock.c: Unable to set SIP RTP TOS to 184, may be you have no root privileges
chan_sip.c: Call from ‘111’ to extension ‘222’ rejected because extension not found.

Any thoughts?

What is the context of your extensions? usually this is from-internal.

In your logfile around this time, do you see a Dial command executed? If so, what are its arguments?

For testing purposes, you could place temporarely a
exten => 222,1,Dial(SIP/222,30,t) in your [from-internal-custom] context, and see fi it gets executed

If dialing the SIP/222 fals, there is probably a problem with your sip registration

If you do a sip show peers, what is the actual output?

Just to let everyone know I have managed things to work properly. I am not sure what I did exactly. I know I removed existing extensions (11 and 777) and added 111 and 222 (and possibly some other minor changes) and suddenly things started working as expected. At the time I wrote the initial post my extensions were 11 and 777 but for simplicity I merely renamed them in my post. Later on I really changed them but I can’t believe that was the actual trigger to make things work normally.

Thanks for the help anyway.


So that you know asterisk 1.6 is in Alpha release, FreePBX is currently offically supporting 1.2 and 1.4 but at this time has no offical support for 1.6 (they have been adjusting the code to make it work but nobody can currently garentee that everything will or does).

If you find something not working please post it as bug in the bug tracker (left hand side of webpage, development site, bug Report).