Extension Module Port Setting

I have changed the port setting in the extension module but have not been able to connect using that new port. My router forwards the port to FPBX and the phone is set to the new port. Is this a known working feature at this point?

That is not how that setting works. You are still bound to 5060 so you can only register to 5060. You need to change the bind port in sip settings.

Oh, and I assume that would change the port for all SIP devices. What is the extension port setting used for?

That tells Asterisk how to reach the device. Not how the device reaches Asterisk. Asterisk can only bind to 1 SIP Port for inboud traffic.

OK, so:

  1. If I port forward something like 5070 to 5060, and
  2. Set the Extension Module port to 5070, and
  3. set the phone to 5070…

Do you expect that it will work?

Turns out, when I set the Extension Module port to 5161, it breaks my registration for my VOIP trunk.

I was hoping to find a way to have only remote extensions access the PBX via a non-standard port.

One way is to have your various sip stacks listen on a non-standard port(s) and redirect only vsps:5060 and anyhost:non-standard to pbx:non-standard port on your router, it is better to have your vsp’s use the non-standard port for sip signalling but that is not always possible. To prevent drive-by attempts I suggest that 5070 is only a little less likely to get attention, use something above 1024 but way away from 50nn

By the way, I have altered my iax port in IAX2 Settings and it is working fine but the default port, 4569, continues to be shown in the Extension Module port setting for IAX. This is potentially a source for confusion. This may be not be the case in 13, I can’t say.