Extension does not receive call but makes normal call

And I have a problem with a single extension, the 300, it makes a normal call, records the audio, but does not receive a call.
when I run the command:

asterisk*CLI> pjsip show endpoints

Endpoint: 300/300 Not in use 0 of inf
OutAuth: 300-auth/300
InAuth: 300-auth/300
Aor: 300 1

Endpoint: 301/301 Not in use 0 of inf
OutAuth: 301-auth/301
InAuth: 301-auth/301
Address: 301 1
Contact: 301/sip:[email protected]:5060;ob c2319ded08 Avail 0.878

But when I see the extensions that are logged in:

asterisk*CLI> pjsip show contacts

Contact: 3-Algar/sip: 0cbc5e94ef Avail 6.656
Contact: 301/sip:[email protected]:5060;ob c2319ded08 Avail 1.014
Contact: 4-Algar/sip: 0cbc5e94ef Avail 6.051

Extension 300 is not on the list, but when it is connected and I run the command:
asterisk*CLI> core show channels

Channel Location State Application(Data)
PJSIP/0-Algar-000000 (None) Up AppDial((Outgoing Line))
PJSIP/300-000000d6 s@macro-dialout-trun Up Dial(PJSIP/0xx47xx79xx006@0-Al

If anyone has any tips, I’d appreciate it.

here too when he is on call:

asterisk*CLI> pjsip show endpoints

Endpoint: 300/300 In use 1 of inf
OutAuth: 300-auth/300
InAuth: 300-auth/300
Aor: 300 1
Channel: PJSIP/300-000000ef/Dial Up 00:01:26
Exten: s CLCID: “CID:xxxx”

The device is not registered. Until it is registered, no calls can be placed to it. Registration is not required to be able to receive calls from a device.

I understand but how does he manage to make a connection. Because he is logged in normally.
I’ll leave his config here too:
ParameterName : ParameterValue
========================================================== ====================================
100rel: yes
accept_multiple_sdp_answers : false
acl :
aggregate_mwi : true
allow : (alaw|ulaw|g729|g723|g726|g722|gsm|ilbc|speex32)
allow_overlap : true
allow_subscribe : true
allow_transfer : true
aors: 300
asymmetric_rtp_codec : false
auth : 300-auth
bind_rtp_to_media_address : false
call_group :
callerid : “William T.” <300>
callerid_privacy : allowed_not_screened
callerid_tag :
connected_line_method : invite
contact_acl :
context : from-internal
cos_audio : 5
cos_video : 4
device_state_busy_at : 0
direct_media : true
direct_media_glare_mitigation : none
direct_media_method : invite
disable_direct_media_on_nat : false
dtls_ca_file :
dtls_ca_path :
dtls_cert_file :
dtls_cipher :
dtls_fingerprint : SHA-256
dtls_private_key :
dtls_rekey : 0
dtls_setup : active
dtls_verify : No
dtmf_mode : rfc4733
fax_detect : false
fax_detect_timeout : 0
follow_early_media_fork : true
force_avp : false
force_rport : true
from_domain :
from_user :
g726_non_standard : false
ice_support : false
identify_by : username,ip
ignore_183_without_sdp : false
inband_progress : false
incoming_mwi_mailbox :
language: pt_BR
media_address :
media_encryption : no
media_encryption_optimistic : false
media_use_received_transport : false
message_context :
moh_passthrough : false
moh_suggest : default
mwi_from_user :
mwi_subscribe_replaces_unsolicited : no
named_call_group :
named_pickup_group :
notify_early_inuse_ringing : false
one_touch_recording : true
outbound_auth : 300-auth
outbound_proxy :
pickup_group :
record_off_feature : apprecord
record_on_feature : apprecord
refer_blind_progress : true
rewrite_contact : true
rpid_immediate : false
rtcp_mux : false
rtp_engine : asterisk
rtp_ipv6 : false
rtp_keepalive : 20
rtp_symmetric : true
rtp_timeout : 60
rtp_timeout_hold : 300
sdp_owner :-
sdp_session : Asterisk
send_connected_line : yes
send_diversion : true
send_history_info : false
send_parent : true
send_rpid : false
set_var :
srtp_tag_32 : false
sub_min_expiry : 0
subscribe_context :
suppress_q850_reason_headers : false
t38_udptl : false
t38_udptl_ec : none
t38_udptl_ipv6 : false
t38_udptl_maxdatagram : 0
t38_udptl_nat : false
timers: yes
timers_min_se : 90
timers_sess_expires : 1800
tone_zone :
tos_audio : 184
tos_video : 136
transport :
trust_connected_line : yes
trust_id_inbound : true
trust_id_outbound : false
use_avpf : false
use_ptime : false
user_eq_phone : false

The device has to send a register to FreePBX, which is then authenticated and handled.

Is there any command that I can force this registration, or that I can make the extension disconnect and connect again. Because the strangest that he makes calls to the other extensions, he makes calls outside normally.

There is no “connection”. And you can’t at least from Asterisk force a device to register. If you have some kind of provisioning maybe that would do it.

As I stated previously, registration is NOT required to accept calls from a device.

Got it, how can I make this device force to register?

Someone else may have further information, but I don’t have anything else to add.

What’s the device that you are trying to get to work? You may need to talk to the vendor of the device and ask them how to properly configure it to work with asterisk/FreePBX.

I’m using utech a softphone, and I use this same application for several people here in the company and it works, only this one doesn’t.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.