Everything works but FreePBX has no internet! 2 Nic

my FreePBX works with 1 ethernet card and everything works great. My ISP and i had to make change and put my voip router in bridge mode. So i had to place a second nic in my FreePBX box. Now i have eth1 (the old one) and eth2(the new one).

  • My eth1 is configured to see my local lan, where the SIP Phones are. My network is
  • My eth2 is configured to see the ISP’s Voip router in order to bypass the telephony service. The network between my FreePBX and ISP router is

I have configured my gateway to be through my eth1. And everything is working great!! My telephony system works and i tried ping google.com or and it works, too. But…
my FreePBX amportal cannot connect to the internet (!!). I realized that when i go to Admin -> System Admin and it said that my FreePBX needs activation (i have already done it when i installed it for the first time).
After that i went to Admin -> Module Admin and press the button Check Online, a popup is showing “Checking Online, Please Wait…” and after a while(3-4m) i get the following warning “Warning: Cannot connect to online repository(s) (http://mirror1.freepbx.org,http://mirror2.freepbx.org). Online modules are not available.

Any ideas ?

You haven’t changed your network settings to identify the 192.168.100.x network as the default route out to the Internet.

Only eth1 in network is connected to the internet. The gateway is and it is configured properly. I have tested in terminal and i can ping successfully but i found out that i couldn’t ping google.com, so my problem is DNS!!

I manually enter into /etc/sysconfig/network-scripts/ifcfg-eth1 and ifcfg-eth2 the DNS1= and DNS2= and finally everything is working :smile:

1 Like