Eutelia Registration TimeOut

Please HELP !!!
I’m going krazy !!!

I installed the FreePBX Distro
* Redhat CentOS release 5.5 (Final)
* Ver. FreePBX: (2.9.0)

All works fine for about one week,
then, during a night, all external trunks fail to register

[2011-09-03 16:44:42] NOTICE[26744] chan_sip.c: – Registration for ‘[email protected]’ timed out, trying again (Attempt #8)

This happens with ALL thruks.

If I connect directly to provider with a softphone (X-Lite) it work,
so, I suppose, isn’t a provider problem.

I reloared a backup of a date before the problem,
but nothing changes

Trunks are configured as follow:

Peer Details

username=011xxxxxxx
type=friend
srvlookup=yes
secret=zzzzzz
realm=voip.eutelia.it
qualify=yes
nat=yes
insecure=very
host=voip.eutelia.it
froromdomain=voip.eutelia.it
fromuser=011xxxxxxx
dtmfmode=inband

User Details

username=011xxxxxxx
user=011xxxxxxx
type=friend
secret=zzzzzz
insecure=very
host=voip.eutelia.it
fromuser=011xxxxxxx
context=from-pstn

Register String

011xxxxxxx:zzzzzz:[email protected]:5060/011xxxxxxx

Can anyone HELP ME !!!

Many tks in advance
Charles

First stop yelling (with the capitals and explanation points), it doesn’t make anyone want to help you.

This sounds like a network issue with the Asterisk box. Perhaps you don’t have the qualify option set and the NAT translation is timing out in your firewall?

Can you ping voip.eutelia.it from the server when you are having this problem?

If you can ping enable SIP debug to the IP address of voip.eutelia.it’ (sip set debug ip xx.xx.xx.xx) and see if the data in the log (/var/log/asterisk/full) offers any clues.

during a night ? at 16:44:42 ? you also need to provide more details about your setup.

Ok, thanks.
Yes during a night, exactly,
system was working at 22 of 1/9 (8 trunks online), at 9 of 2/9 0 trunks online.
The line reported is only what happened at 16:42:43 of 3/9 (today).
I preferred don’t put 3000 lines of equals messages.

At the moment I resolved this way (found “googling” around the web)
Power off Asterisk machine - wait at least 30 min - power on.

Now I have 7/8 trunks online.

Why??? I don’t know.

In any case the provider (voip.eutelia.it) was reachable from the machine,
also when not working.

Now i leave the machine on test.
I don’t understand why a simple power-off and on, or a reboot, don’t resolve; but needs 30-60 min of pause.

If the situation repeat, i will program power off at 3:00 and power on at 4:00.
But seems crazy

I will inform advise on future development.

Thanks,
Charles

The pause indicates my first theory. You have some type of NAT timeout going on downstream from the server.

As first:
Many thanks for assistance, is greatly appreciated.

This morning the problem has repeated.
Follow a summary of “full” log file.

I set the qualify options on extensions and Peer details.
When i restart machine, i will put qualify=yes also in User,
and Qualifyfreq=60 on both;
may be useful?

Now machine is stopped and I’m waiting for 60 min pause.
Yust for information, is a virtual machine on VMWare Server 2.0,
over a UBUNTU 10.0 Server; to be moved on ESXi in few days.

My real problem is that I can’t find a complete reference on FreePBX,
some info (very confused) can be found on general asterisk,
but GUI take complete control of .conf files,
and i never know where are real files.
Is my opinion that is better not mix manual and gui generated config,
so I prefer to operate by GUI only. (whenever is possible).

obviously, xx.yy.zz.ww is my public IP.

…omissis…
[2011-09-04 04:02:21] VERBOSE[15047] logger.c: Asterisk Queue Logger restarted
[2011-09-04 04:02:21] VERBOSE[15047] asterisk.c: – Remote UNIX connection disconnected
[2011-09-04 04:02:25] NOTICE[2702] chan_sip.c: – Registration for ‘[email protected]’ timed out, trying again (Attempt #218)
[2011-09-04 04:02:45] NOTICE[2702] chan_sip.c: – Registration for ‘[email protected]’ timed out, trying again (Attempt #219)
…omissis…
[2011-09-04 08:54:17] NOTICE[2702] chan_sip.c: – Registration for ‘[email protected]’ timed out, trying again (Attempt #1090)
[2011-09-04 08:54:30] VERBOSE[2829] asterisk.c: Beginning asterisk shutdown…
…Asterisk Reboot
…sip set debug ip 83.211.227.21
…omissis…

[2011-09-04 09:29:51] VERBOSE[2701] chan_sip.c: Retransmitting #6 (NAT) to 83.211.227.21:5060:
REGISTER sip:voip.eutelia.it SIP/2.0
Via: SIP/2.0/UDP xx.yy.zz.ww:5060;branch=z9hG4bK1b6ff445;rport
Max-Forwards: 70
From: sip:[email protected];tag=as2d781a8b
To: sip:[email protected]
Call-ID: [email protected]
CSeq: 113 REGISTER
User-Agent: FPBX-2.9.0(1.8.5.0)
Expires: 120
Contact: sip:[email protected]:5060
Content-Length: 0
…omissis…

[2011-09-04 09:29:56] VERBOSE[2701] chan_sip.c: Really destroying SIP dialog ‘[email protected]’ Method: REGISTER
…omissis…

[2011-09-04 09:29:57] VERBOSE[2701] chan_sip.c: Reliably Transmitting (NAT) to 83.211.227.21:5060:
OPTIONS sip:voip.eutelia.it SIP/2.0
Via: SIP/2.0/UDP xx.yy.zz.ww:5060;branch=z9hG4bK1d7eb686;rport
Max-Forwards: 70
From: “Unknown” sip:[email protected];tag=as7a332ca9
To: sip:voip.eutelia.it
Contact: sip:[email protected]:5060
Call-ID: [email protected]:5060
CSeq: 102 OPTIONS
User-Agent: FPBX-2.9.0(1.8.5.0)
Date: Sun, 04 Sep 2011 07:29:57 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
Content-Length: 0


That’s really not much info. Did you reboot at the beginning of the log?

What I am trying to see is if the register messages go unanswered.

With regard to the config files you should not have to modify them for most situations. FreePBX provides “hooks” if you must modify in the form of the files with the “custom” filename.

What Asterisk options do you find confusing? You can use any of the SIP peer level variables in a FreePBX trunk.

No, the log start some lines before.
Seems the queue of a automatic reboot,
but I don’t reboot at 4:00,
next time i will save the file before set debug
that’s space consuming and kick out first lines (i suppose).

What I discovered is that in these days my provider is working
on the net, with some interruption between 2:00 and 4:00 AM.
May be the original cause.
So I suppose tomorrow morning the problem will be repeated.

Now I have to investigate on automatic restart of registration.
I repeat, softphones connect directly without problems.
Also I disabled (for now) firewall rerouting of ports 5060 and 10000-20000,
the extern access is done via VPN.

For my confusion on asterisk…
I’m searching for a list of available options, their scope and use.
In the web you can find people that say :
use this config for provider1 or this other for provider 2.
My configuration (first post) is very different from default,
I copied from a italian forum,
but I don’t know the significance of 1/2 of the options used.
Nor know the existance of other (possibly useful) options.

As example the registration string:
Number:Passwd:[email protected]:5060/Number
seems a Abracadabra.
No online help explain that you need this structure,
but if you use the default string:
Number:[email protected]:5060
don’t register.

Just an information (sorry):
the RTP ports are 10000 to 20000, and any communication use 4 to 30 ports.
But a great part provider require to set RTP to 8000 in SIP phone.
I understand that the first set op port are dinamically choosen
during negotiation,
but what’s the significance(use) of the fixed port 8000 ?

Thanks thanks thanks.
Charles

I have never seen a fixed RTP port configuration. RTP ports are assigned in the SDP as part of the invite.

Sorry for the delay, but I was traveling.

I discovered that the problem start when firewall reboot.
(there is a rule that try to reboot the firewall
after 15 min without connection).

If I manually reboot firewall I reproduce the problem.
I suppose that the route in some way change with reboot.
But, in anycase, I don’t understand.
If I register a softphone instead of Asterisk, nothing happens.
Softphone (XLite) and asterisk use, is evident, different policies to register.

for RTP port, this is from Grandstream HT386 manual
Local RTP port:
This parameter defines the local RTP-RTCP port pair the HT-386 will listen
and transmit. It is the base RTP port for channel 0. When configured, channel
0 will use this port_value for RTP and the port_value+1 for its RTCP; channel
1 will use port_value+2 for RTP and port_value+3 for its RTCP. The default
value for FXS1 is 5004, FXS2 is 5008.

Xlite default to port 8000 and Samsung WiFiPhone use 12000.
But, as you said, RTP port is assigned dinamically ???
I’m confused (more) !

Tks