Errors installing FreePBX 14 on flash drive


(M D ) #1

I’m trying to install FreePBX 14 on a new Mini PC with 32Gb of onboard flash storage as the only storage device. I am getting this error:

The following problem occurred on line 2 of the kickstart file:

Disk “” given in clearpart command does not exist.

Exception AttributeError: “‘NoneType’ object has no attribute ‘undev_unref’” in <bound method Context.del of <pyudev.core.Context object at 0x7f2be71f6cd0>> ignored

From the logs:
anaconda: Running kickstart %%pre script(s)
anaconda.stdout: Running pre-installation scripts
anaconda: Error code 1 running the kickstart script at line 24

Appreciate any assistance on this - thanks!


(M D ) #2

I was able to install CentOS 7 manually on my mini PC and then successfully installed FreePBX 14 using the manual instructions. So there is nothing wrong with my mini PC, drivers, storage devices, etc as far as installing and running FreePBX 14. However, the FreePBX 14 distro still will not install with the same error - Disk “” given in clearpart command does not exist.

I would very much like to find a solution to this but I don’t have the chops troubleshoot this beyond the very basics. I want the self-contained distro installed so the system can be managed within FreePBX rather than having to manage CentOS separately.

Is there anyone out there who can give me some pointers on troubleshooting this further?


(Menace208) #3

I am having the same exact problem with my Zotac zbox pi331. The problem is that the freePBX distro install does not recognise the built-in eMMC drive and therefore cannot find anywhere to install. This can be seen if the advanced installation option is chosen and the GUI of the install is seen.
During the initialisation phase I can see an error something like "error 22 error initialising MMC device "or something to that effect since it flashes by too quickly.

I too am able to install centOS 7 manually without any issues.

Hopefully this issue can be resolved quickly!


#4

Got exactly the same problem, from a single USB disk installation attempt of
SNG7-FPBX-64bit-1707-1
downloaded onto the usb via Rufus in dd mode
Compfused
Edit…wonder if its due to this code within the /kickstarts/disconf.cfg file:

# Automatically ignore any removable devices # if [[ $RM == 1 ]]; then continue; fi


(Brian Martin) #5

compused is correct. The installation routines look for devices to install to, but filter out ones identified as removable. If there are no more disks left after the filtering, the “Disk “” given in clearpart command does not exist.” error comes up.

In my case, the installation disks were actual, installed hard drives, but they appeared to be removable to the O/S. I was able to work around it by changing a “Hot-pluggable” option for the disks in my AMI BIOS.


(Dave Burgess) #6

Maybe you should submit a ticket. I, too, use hot-swapable drives on many of my servers and would be mightily upset if the system decided I couldn’t be trusted with this. It would also make installing to a Thumb Drive theoretically simpler (maybe).


(Brian Martin) #7

It appears that I need paid support to submit a ticket, which I don’t have. That sounds like an odd way to run an open-source project, so maybe I’ve found the wrong support site. Do you have any insight for me on how to open one?


(Rob Thomas) #9

It’s a deliberate choice to not auto-install to removable media. If you want to do that, you’ll need to use Advanced Install, and pick your drive manually. Sorry, even if you open a ticket, I’m going to say ‘Not going to fix’ – We’ve had far too many people accidentally install over their installing USB drive without realising.

Saying that, if you do have an issue, the place to report them is issues.freepbx.org


(M D ) #10

Seems the algorithm for determining removable media could use some improvement. Identifying permanently installed flash media (ie: soldered to the system board) as removable media seems rather questionable. Mini PCs seem to have this permanent flash media as their primary (or only) storage intended to host whatever OS the user puts on the device.


(Rob Thomas) #11

It’s pretty basic. “Does the device say it’s removable media? If so, it’s removable”.

Run ‘lsblk -a’ on your computer and look at the ‘RM’ column. Either way, this only affects automatic installs. If you just pick Advanced, you can do whatever you want.

[root@sng7 sangoma-pbx]# lsblk -a
NAME                  MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
fd0                     2:0    1    4K  0 disk
sda                     8:0    0   80G  0 disk
├─sda1                  8:1    0    2G  0 part /boot
└─sda2                  8:2    0   78G  0 part
  ├─SangomaVG-root    253:0    0 70.1G  0 lvm  /
  └─SangomaVG-swaplv1 253:1    0  7.9G  0 lvm  [SWAP]
sr0                    11:0    1 1024M  0 rom
[root@sng7 sangoma-pbx]# lsblk -

(M D ) #12

I wonder why the drives would have the RM bit set then, when they are obviously not RM. Will try the Advanced option to get around it - thanks for the feedback.


#13

Yes, installing via the Advanced options works. Note there are two ‘Advanced’ install options

  1. Freepbx…Advanced <—works
  2. Advanced… <–does not work
    I tried commenting out the relevant lines as I indicated above in 2017:
    # Automatically ignore any removable devices # if [[ $RM == 1 ]]; then continue; fi
    this leads to an installation but without proper disc size formatting and with other problems
    HTH
    Compused