Error while installing soundlang module

Good day everyone!

I stuckd with a trouble. First of all, if the Russian language is installed in the Sound Languages module, then in the settings you set Global Language - Ru - the following happens in the console:

<SIP/1371-00000000> Playing 'digits/12.slin' (language 'ru')
       > 0x7f01f8025f30 -- Strict RTP learning complete - Locking on source address 192.168.5.105:8000
    -- <SIP/1371-00000000> Playing 'digits/18.slin' (language 'ru')
    -- <SIP/1371-00000000> Playing 'vm-and.slin' (language 'ru')
    -- <SIP/1371-00000000> Playing 'digits/40.slin' (language 'ru')
    -- <SIP/1371-00000000> Playing 'seconds.slin' (language 'ru')

We see that the language is used Russian, but the phrases are pronounced in English and in the format .slin. I tried to add a custom language manually, but the problem is the same.

Then i tried to deletesoundlang module and its dependencies: fwconsole module delete ivr conferences findmefollow recordings soundlang

Then i execute: fwconsole module downloadinstall soundlang

[email protected]:/var/lib/asterisk/sounds# fwconsole ma downloadinstall soundlang
No repos specified, using: [standard,extended,unsupported] from last GUI settings

Downloading module 'soundlang'
Processing soundlang
Verifying local module download...Verified
Extracting...Done
Download completed in 5 seconds
Updating tables soundlang_packages, soundlang_settings, soundlang_customlangs, soundlang_prompts...Завершено
New install, downloading default english language set...
Installing core-sounds-g722...Завершено
Installing core-sounds-ulaw...Завершено
Installing extra-sounds-g722...Завершено
Installing extra-sounds-ulaw...Завершено
Finished installing default sounds
Installing additional package core-sounds-alaw...Завершено
Installing additional package core-sounds-alaw...
In Soundlang.class.php line 1123:

  SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column 'filename' at row 1

I began to look for column named filename, and found it in table soundlang_prompts with varchar(80). There is about 4200 rows of data. I tried to

ALTER TABLE soundlang_prompts MODIFY COLUMN filename VARCHAR(100); (or 1000 or 2000)

but after i run downloadinstall soundlang the column still varchar(80).

I can’t find a command in install files that make this column exactly varchar(80).
I tried to rename or delete soundlang tables, after that the script said “new install downloading “en” package”, but… the same error

My build is Ubuntu 18.04.1 (not live), Current PBX Version: 14.0.5.25.

upd: just found, i had to do:

rm -rf /var/lib/asterisk/moh
ln -s /usr/share/asterisk/moh /var/lib/asterisk/moh
rm -rf /usr/share/asterisk/sounds
ln -s /var/lib/asterisk/sounds /usr/share/asterisk/sounds
chown -R asterisk.asterisk /usr/share/asterisk

on another system it make the asterisk speaks russian. now i have to install soundlang module on actual system, but it tells me an error

upd:
just commented the lines which installing additional modules in install.php, and it installed succesfully. then i install recordings, ivr etc, refreshsignatures and apply config correctly in webgui.
but i think it is not correct way to fix it…

I have not tried to add a language in a couple years. This sounded reproducible, I would suggest you open an issue

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.