Error when I try to activate

Hi!

I try to activate my FreePBX but I get the above error message.
Any hint ?

Very best, Fredrik


Activation Status
Error in 

/var/www/html/admin/modules/sysadmin/Reg.class.php: exception
’Exception’ with message ‘Unable to get Zend ID’ in
/var/www/html/admin/modules/sysadmin/Reg.class.php:83
Stack trace:
#0 /var/www/html/admin/modules/sysadmin/Sysadmin.class.php(910):
FreePBX\modules\Sysadmin\Reg->getDeploymentID(‘[email protected]’, ‘My location’, false)
#1 /var/www/html/admin/modules/sysadmin/Sysadmin.class.php(140):
Sysadmin->doActivateSilent(Array)
#2 /var/www/html/admin/libraries/BMO/Ajax.class.php(111):
Sysadmin->ajaxHandler()
#3 /var/www/html/admin/ajax.php(49): Ajax->doRequest(‘sysadmin’,
‘doactivate’)
#4 {main}

If you are getting that error it’s because we are unable to get a Zend ID. Can you tell us how you installed (is this a FreePBX Distro or not)? Also can you post the output of the following:

php -r 'print_r(zend_get_id());'

I used this guidline to install FreePBX as I run it on a virtual server where I only have a limited number of distros to choose from:

http://wiki.freepbx.org/display/HTGS/Installing+FreePBX+12+on+CentOS+6.5

The output of:
php -r ‘print_r(zend_get_id());’

Array
(
)

@freuter,
That’s the reason you are unable to activate, as your system doesn’t have a Zend ID. You may want to take a look at the wiki on installing commercial modules on Redhat based systems which should get you the remaining pieces you need to be able to register your system.

@GameGamer43 Hi, i’m trying to activate my freepbx distro 6.12.65 and receive the sysadmin pro package, and i get the same error, but i have a zend_id:

[[email protected] ~]# php -r 'print_r(zend_get_id());'
Array
(
[0] => M:7HRBY-22YN2-EDBXT-JVVFR
)

I’ve tried so many times, aborted, and tried again, and nothing. Could you please guide me on it?

Thnx in advance.

@ivanofmg, You shouldn’t be seeing the same error as above based on the output of the zend_get_id command you posted above. Can you please let me know what version of Sysadmin you are using as well as paste the error you are seeing on the screen so that we can try to dig in further?