Error using Bulk Handler (13.0.14.8) in FreePBX (14.0.10.3)

modules
Tags: #<Tag:0x00007fafbfce7950>

(daxm) #1

I wrote a Python package to assist in building the CSV file needed for the Bulk Handler module. The last time I used it (a few months ago) it worked fine. Since then I’ve updated my phone system to the latest version and latest modules. Now my created CSV file no longer works.

I get an error like this:
“SQLSTATE[HY093]: Invalid parameter number: number of bound variables does not match number of tokens File:/var/www/html/admin/libraries/BMO/Database/PDOStatement.class.php:17”

I’ve performed an export and cross-checked that my import CSV file has the same number of fields (columns). I had to add 2 new fields to make that align but I continue to get the same error.

Anyone have a solution for me?

Note: the Python package is in PyPi as freepbx_bulk_handler, if you want to try it out.


(Andrew Nagy) #2

Upgrade framework.


(daxm) #3

Care to elaborate? I thought I had upgraded to the most recent.


(Mvogel4949) #4

I think the VM module also plays a role

https://issues.freepbx.org/browse/FREEPBX-19798


(daxm) #5

Thank you! I tried upgrading Bulk Handler to edge and that didn’t fix it. I then updated Voicemail to edge and that did fix it!


(Mvogel4949) #6

How does your python script make the bulk handler easier to use?


(daxm) #7

It can take a source CSV file of your extensions (and other data related to the extension) and builds a CSV file that will work for importing using the Bulk Handler.

My brother has a charity that has “chapters” that are changing often (some adds, some deletes). Just grabbing a CSV of all the extensions is an easy way for me to update all the frequent changes he makes.


#8

I have the same issue. Not able to bulk add.

Bulk Handler 13.0.14.8
Feature Code Admin 13.0.6.4
Voicemail 14.0.6.2

The system was installed today.


(Andrew Nagy) #9

Did you read the post above?


#10

I did read it. My modules are up to date or newer than the online version. I tried enabling edge mode as well. I am not able to get newer module versions.

FreePBX Framework 14.0.8.4

Not sure if it matters but this is a PBXact system


(Andrew Nagy) #11

I dont think you did. In the ticket it says fixed in voicemail 14.0.6.6 and you said you have voicemail 14.0.6.2


#12

I know I did, three times actually.
Just checked for updates again and still see the same version voicemail module. I have a separate FreePBX system that does show 14.0.6.6, but I am trying to bulk add on a PBXact system



(Kapil Gupta) #13

Try below cli command. SSH to Freepbx and execute below command

fwconsole ma downloadinstall voicemail --tag 14.0.6.6

if above command also does not install edge release then re-confirm if you have proper license of upgrading module.


#14

I receive an error “-Retrieved Module XML Was Empty”

How do I check the proper license of upgrading module? The system has voicemail.


(Mvogel4949) #15

Settings --> Advanced Settings --> Set Module Edge Update to Yes then go back to Module Admin and check online. Upgrade just the VM module and then try the bulk handler


(Itzik) #16

I don’t think this will make a difference.

fwconsole ma downloadinstall voicemail --tag=14.0.6.6

One more thing: I remember reading here, that PBXact users can only install modules that have a QA Pass. Looking at the ticket that was posted here, it seems that it only has a QA Review, not a pass. Not sure if it’s related to this…


#17

I’m not sure what happened but I am able to complete bulk import and exports now.


(Michael) #18

I ran into this same error and running fwconsole ma downloadinstall voicemail --tag 14.0.6.6 fixed my problem


#19

Enabling edge mode and upgrading the voicemail module to 15.0.18.7 fixed the issue for me. See FREEPBX-20460 which is fixed in 15.0.18.7 of the module.


(Tom Ray) #20

The v15 track is for v15 which is still BETA. So that fix doesn’t do anything for those on v14/v13 if this problem exists for them.