Error updating forms [SOLVED]


(Claudio Pelosi) #1

I was updating Framework FreePBX15.0.16.22
And here is this error:

Please wait while module actions are performed
Downloading and Installing framework
Downloading framework 16079046 of 16079076 (100%)
Error (s) downloading framework:
File Integrity failed for /var/www/html/admin/modules/_cache/framework-15.0.16.53.tgz.gpg - aborting (GPG Verify File check failed)
Updating Hooks … Done


(Claudio Pelosi) #2


(Kapil Gupta) #3

Hi @claloano Please try below cli command

fwconsole ma downloadinstall framework --tag=15.0.16.53 --force


(Claudio Pelosi) #4

Responds with this error:
root@raspbx:~# fwconsole ma downloadinstall framework --tag=15.0.16.53 --force
No repos specified, using: [standard] from last GUI settings

Starting module download from https://mirror.freepbx.org/modules/packages/framework/framework-15.0.16.53.tgz.gpg
Processing
Downloading…
16079076/16079076 [============================] 100%
Finished downloading
Extracting…The following error(s) occured:

  • File Integrity failed for /var/www/html/admin/modules/_cache/framework-15.0.16.53.tgz.gpg - aborting (GPG Verify File check failed)

(Kapil Gupta) #5

Whats your current framework release ?

May be you try to download latest edge release.

fwconsole ma downloadinstall framework --tag=15.0.16.55


(Claudio Pelosi) #6

it gives me this error anything i want to update


(Claudio Pelosi) #7

i am using latest official downloadable version of raspbx :
http://www.raspberry-asterisk.org/downloads/

Contents Asterisk 16.6.1 & FreePBX 15.0.16.22


(Claudio Pelosi) #8

This worked to solve the issue

fwconsole ma upgrade framework --tag 15.0.16.38


(Comfine GmbH) #9

just want to add that i was struggeling with this problem aswell, but all modules could not be upgraded, not only the framework, cause of GPG check failed.

after framework was upgraded with command from claloano
fwconsole ma upgrade framework --tag 15.0.16.38

i could update after a reload in the GUI all other modules aswell, and i could also upgrade to the latest framework 15.0.16.56