Error updating Distro


(Greg) #1

When I try to run yum update I get the following error. I’ve found many others with similar issues but can’t seem to find a resolution for my specific case.

Error: Package: glibc-common-2.17-222.el7.x86_64 (@anaconda/1805)
           Requires: glibc = 2.17-222.el7
           Removing: glibc-2.17-222.el7.x86_64 (@anaconda/1805)
               glibc = 2.17-222.el7
           Updated By: glibc-2.17-307.el7.1.x86_64 (sng-base)
               glibc = 2.17-307.el7.1
 You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
32:bind-license-9.11.4-16.P2.el7_8.6.noarch is a duplicate with 32:bind-license-9.9.4-61.el7.noarch
glibc-common-2.17-307.el7.1.x86_64 is a duplicate with glibc-common-2.17-222.el7.x86_64
glibc-common-2.17-307.el7.1.x86_64 has missing requires of glibc = ('0', '2.17', '307.el7.1')
libgcc-4.8.5-39.el7.x86_64 is a duplicate with libgcc-4.8.5-28.el7_5.1.x86_64
tzdata-2020a-1.el7.noarch is a duplicate with tzdata-2018e-3.el7.noarch

Asterisk 13.38.3 built by mockbuild @ jenkins7 on a x86_64 running Linux on 2021-09-03 09:40:38 UTC
FreePBX 14.0.16.11

Any help would be much appreciated.


(Jared Busch) #2

You should not be pulling updates for el7 packages from (@anaconda/1805)

Was this a FreePBX 13 upgraded to FreePBX 14? You may have a leftover repo.