Error : no line is available

dahdi
Tags: #<Tag:0x00007f4f44fe0368>

(Titouan Planson Jeullain) #1

Hi,

I allow myself to come and ask for your help, I have a freepbx server with an openvox 4 ports card, I manage to receive calls but I cannot send them, it tells me that no line is available.
I hope you can help, I would be very grateful to you;

Thank you very much,
Titouan


#2

Is this a new system, or one that was in service and suddenly stopped working?
If the latter, are you aware of anything that may have caused the trouble (software update, power failure, etc.)?

What is “it” (an error announcement you hear, error message displayed on your phone, error message on the console, error in a log file, etc.)?

If appropriate, paste the Asterisk log for a failed outgoing call attempt at pastebin.freepbx.org and post the link here.


(Titouan Planson Jeullain) #3

The system is a new install, when I call a number I hear this: “all lines are busy at the moment, please try later”


#4

OK, so paste the Asterisk log for a failed outgoing call attempt at pastebin.freepbx.org and post the link here.

The Asterisk log can be viewed at Reports -> Asterisk Logfiles, or you can click the download button there to get the entire file. The raw file is at
/var/log/asterisk/full
Select the portion for the failed call. The first line of your call will contain
Executing [1234@from-internal:1]
where 1234 is the number you dialed.


(Titouan Planson Jeullain) #5

Here are the logs when I make a call : 1deeb346
Sorry I couldn’t put the link, I’m too new to it…


#6

It appears that the call was blocked by the Extension Routing module, though I don’t understand why you didn’t get the ‘cannot be completed as dialed’ message.

For the Outbound Route that should match the 02 number that you called, click the Additional Settings tab and make sure that your extension 100 is included in the Allowed Extensions list. On the Route Settings tab, make sure that your dahdi trunk is listed.

If you still have trouble and don’t expect to be restricting calling on a per-extension basis, try disabling the Extension Routes module.


(Titouan Planson Jeullain) #7

I just looked in the route settings, where should the dahdi trunck be listed ?
I also disable the routes extension module.


#8

On the Route Settings tab, you should see a section Trunk Sequence for Matched Routes
For each entry (you probably need only 1), there is a pulldown list which should allow you to select your dahdi trunk. If you don’t see that, you might have to first add a trunk under Connectivity -> Trunks. However, because you have incoming working, I believe that the trunk is set up correctly and you shouldn’t have to add one.


(Titouan Planson Jeullain) #9

Indeed, I did not have a dahdi trunk to select but unfortunately that does not change anything yet


#10

Try another test call and paste the new log.


(Titouan Planson Jeullain) #11

here are the new logs : https://pastebin.freepbx.org/view/e08ccf7f

Thanks again for the help


#12

The Restricted Route stuff is now gone, but AFAICT there are still no trunks associated with the route.
Please post screenshots of the Outbound Route (Route Settings and Dial Patterns tabs) and the Trunk (General tab). Also, post the contents of your
/etc/asterisk/chan_dahdi.conf


(Titouan Planson Jeullain) #13

Here are the captures :


for chan_dahdi.conf :



#14

The route was correctly identified but the macro to dial on the trunk was not called, so I’m guessing that the trunk configuration is somehow incomplete or disabled.

The screenshot for the General tab of trunk ‘num1’ is missing. Please post that.

Also, if they exist, post the contents of
/etc/asterisk/chan_dahdi_general.conf
/etc/asterisk/chan_dahdi_groups.conf
/etc/asterisk/chan_dahdi_additional.conf


(Titouan Planson Jeullain) #15

General tab of trunk ‘num1’ :



/etc/asterisk/chan_dahdi_general.conf :

/etc/asterisk/chan_dahdi_groups.conf :

/etc/asterisk/chan_dahdi_additional.conf :


(system) closed #16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.