Error: Line unregistered, Polycom IP 650

i finally got provisioning to work, so my phone loads. now i can’t get the phone to register with the Asterisk/FreePBX system.
I suspect i am not imputing the password correctly, or not grabbing the correct password. i have tried the password given when i created the extension, and i have tried grabbing Secret from Applications -> Extensions, from the one (so far) extension i have. i have also tried the “password for new user”. where do i grab the password from?


Many older devices have limitations on password length or character set. Manually edit the Secret for your extension to e.g. eight characters, using only letters and digits. Carefully update the phone’s SIP password with the same data.

If you still have trouble, at the Asterisk console do
pjsip set logger on
sip set debug on
according to extension type.

Reboot phone and report whether attempts to register are reaching the PBX and what responses, if any, are sent back.

[2018-10-02 17:29:06] WARNING[15660]: res_pjsip_registrar.c:989 registrar_on_rx_request: Endpoint 'anonymous' has no configured AORs

Thanks for responding.
i have shortened the secret to 8 chars, with no change in results.

as for the second point, i entered both commands to the CLI, and “pjsip set logger on” resulted in:

[2018-10-02 17:33:07] WARNING[15660]: res_pjsip_registrar.c:989 registrar_on_rx_request: Endpoint 'anonymous' has no configured AORs
<--- Received SIP request (604 bytes) from UDP: --->
SUBSCRIBE sip:[email protected] SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bKfe1682df8243DD0
From: "Line 1" <sip:[email protected]>;tag=A952CDA1-417D5C7A
To: <sip:[email protected]>
Call-ID: [email protected]
Contact: <sip:[email protected]>
Event: message-summary
User-Agent: PolycomSoundPointIP-SPIP_650-UA/
Accept-Language: en
Accept: application/simple-message-summary
Max-Forwards: 70
Expires: 300
Content-Length: 0

<--- Transmitting SIP response (376 bytes) to UDP: --->
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP;rport=5060;received=;branch=z9hG4bKfe1682df8243DD0
Call-ID: [email protected]
From: "Line 1" <sip:[email protected]>;tag=A952CDA1-417D5C7A
To: <sip:[email protected]>;tag=z9hG4bKfe1682df8243DD0
Server: AsteriskNow-

i picked up on “…SIP/2.0 404 Not Found…” in the TX. perhaps i have the extension configured incorrectly?


Did you create a pjsip extension? If it’s a chan_sip extension, you’ll need to set the phone to register to port 5160 (or whatever you set Bind Port to), change the ports around so chan_sip is on port 5060, or change the extension to use pjsip.

If it’s a pjsip extension:

Go to Applications -> Extensions and confirm that 4000 appears in the list and type shows as pjsip. Click the Edit button for 4000 and confirm that Secret is the value you set.

Confirm that you’ve done an Apply Config. Try restarting Asterisk, by typing
fwconsole restart
at a root shell prompt.

If you still have trouble, post the contents of
(mask passwords, phone numbers and anything else you consider personal).

The SIP that you captured was an attempt to subscribe to voicemail notifications; the registration attempt likely occurred before the capture was started. Reboot phone to see register requests.

changing the port to 5160 did it!
many thanks! i have a dial tone!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.