Error contacting proxy server

I have P320 Sangoma Phone and I have issue after booting up.

The phone don’t response and keep
giving same error message “Error contacting proxy server. You can retry, choose a new server, or reset any stored credentials and then retry.”

I tried to Update & downgrade the firmware but still same.

I tried to configure manually but same

Do other P320s on your network work just fine? Have you verified that the phone is connected to the correct network and receiving a correct/expected IP address?

Yes I have P325 And its fine IP is correct and I can access it with web interface

Hmm, try assigning the phone’s mac address to an extension in the PBX GUI first and see if that will work. If you are using DMPA to provision the phones you can check/watch the asterisk logs /var/log/asterisk/full for the phone attempting to provision.

I tried to provision throw DMPA but still same error also I cheeked the log.

But still same issue I have update Firmware 4.13.5 but still same

I think I have a similar situation, working on some P315 phones, they are new but claimed, they were pointed to a different deployment.

I’m using a Cloud hosted FreePBX, using DMPA for provisioning with VPN enabled.

In the Sangoma portal the devices are not following the “no redirect” setup.

The devices will give me connecting error if they have no IP/FQDN.

If I enter IP/FQDN (with redirect set to “no”) the phone will reach server will connect to the VPN, try to download config files but will reboot and will stay on a loop.

Hope this point you on the right direction.

My server setup is working fine because I tested another “new” device and connects and provision without issues.


The IP/FQDN address looks off. Make sure the deployment is set up correctly in the portal, phones tab, for the D/P Phones. Then set the phone to do Deployment type redirect and select your dep ID.

1 Like

Hi, not trying to hijack the conversation. I;m just giving some context that may help to other users.

I opened a ticket with Sangoma, no matter what I configure on the portal the phone will have the error “contacting server”

Many Many Thanks Guys!

Its work!

Thanks A lot

1 Like

What was your solution?

I have changed the IP/FQDN in Sangoma Portal to My local FreePBX IP then Factory rest the phone

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.