Error[6641] chan_sip.c:4273 Serious Network Trouble; __sip_xmit returns error for pkt data

I am constantly getting this error on a new build of FreePBX 13. I have removed trunks and it still continues. Any idea to fix this would be greatly appreciated. I do have many commercial modules installed but at this point don’t even know where to start.

Ever get this resolved? I’m seeing the same errors.

We are suffering this error. Any idea to solve this? I’ve heard about trunk configuration, but it’s the same config we use in all freepbx machines we have in production, and this error is not present in anyone.

Suggestions? regards

Are you suffering any noticeable problems as a result?

Are you using TCP for SIP?

I’ve tried to set on and off, and got same result. :frowning:
And yes, we are sffering issues, like some daemons stopping: ucp, xmpp, zulu amd restapps :frowning:

Any idea?

Sorry to hear. We’re not using UCP, but seem to only have them on the servers in the environment explained here:

But here’s a post were some other users talk about it seeming to be related to UCP somehow:

Well, I have relized that the errors are originated from the same IPs. They are allways the same and they are connected via VPN, like other extensions.


We have noticed the same. However, we are not using VPNs. What endpoints? And what is their provider? Frontier or Verizon by chance?

Hi Steven,

We are using Yealink phones, T23G are all of them, and we use a local SIP provider, in Europe. anyway, we thnink we have not issues with endpoints. we think zulu’s PCs are who originate this issue, but it’s just an opinion.

We have blocked some IPs and it seems to be a little more stable… we’ll see.


Oh, I was referring to the internet provider, no the SIP provider.

Internet provider is local provider as well. Same provider for both services. Anyway, we don’t think it’s a provider issue. We have several Freepbx machines working in the same datacenter, with same provider.


What version of Asterisk are you running? Somewhere in the 13.15 - 13.17 range?

Also, are you virtualizing? And if so, on KVM?

Interesting that you would ask about KVM virtualization. I don’t want to hijack this thread, but I have seen this error before on an Alpha build of the v7 distro running on a KVM guest. I was just testing it out, so I didn’t dive too deep into it. Are there known issues with running FreePBX on KVM?

12 posts were merged into an existing topic: Consistent Asterisk/FreePBX Crash Issue

I have started receiving this error when we try and use zulu software on laptops. The users have said that when they pick up a call using zulu softphone there is no sound and this error shows in the asterisk logs ERROR[10903] chan_sip.c: Serious Network Trouble; __sip_xmit returns error for pkt data. Has there been a resolution to this ?

Setting a STUN server in Asterisk SIP Settings will often fix audio for external Zulu calls. I don’t think it’s related to the ‘Serious Network Trouble’ errors in the log.

If I understand the problem, setting the STUN server is the right solution for this, since the packets going back to the client have the wrong address otherwise. Note that you should be able to set the “external” address on the Zulu side manually if the “external” IP of the network doesn’t change, but setting the STUN server will work to set that external address in either case.

Was looking for an answer for the same issue ‘__sip_xmit returns error for pkt data’ and only use desktop phones and bria for mobile. Long story short, found the port setting for pjsip (5160 udp / 5161 tls) somehow became empty. Added the port numbers back for UDP and TLS in SIP SETTINGS for PJSIP, submit/apply and then fwconsole restart. Issue solved.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.