Errant fax CNG detection causing hangups

FreePBX Version = 2.8.1.4
Asterisk Version = 1.6.2.18
Phones = Aastra 57i
Carrier = Flowroute - both were outbound calls

Just had two call drops to the same number. While on the call, the person did not hear anything remotely resembling a fax tone. Anyone ever see this before?

[CODE][2011-07-28 10:33:30] VERBOSE[26738] app_dial.c: – Called flowroute-out/1509XXXXXXX
[2011-07-28 10:33:33] VERBOSE[26738] app_dial.c: – SIP/flowroute-out-00002e4b is making progress passing it to SIP/102-00002e4a
[2011-07-28 10:33:35] VERBOSE[26738] app_dial.c: – SIP/flowroute-out-00002e4b answered SIP/102-00002e4a
[2011-07-28 10:34:16] VERBOSE[26738] chan_sip.c: == Redirecting ‘SIP/flowroute-out-00002e4b’ to fax extension due to CNG detection
[2011-07-28 10:34:16] VERBOSE[26738] pbx.c: – Executing [[email protected]:1] Macro(“SIP/102-00002e4a”, “hangupcall,”) in new stack

[2011-07-28 10:34:31] VERBOSE[26799] app_dial.c: – Called flowroute-out/1509XXXXXXX
[2011-07-28 10:34:33] VERBOSE[26799] app_dial.c: – SIP/flowroute-out-00002e4d is making progress passing it to SIP/102-00002e4c
[2011-07-28 10:34:35] VERBOSE[26799] app_dial.c: – SIP/flowroute-out-00002e4d answered SIP/102-00002e4c
[2011-07-28 10:37:18] VERBOSE[26799] chan_sip.c: == Redirecting ‘SIP/flowroute-out-00002e4d’ to fax extension due to CNG detection
[2011-07-28 10:37:18] VERBOSE[26799] pbx.c: – Executing [[email protected]:1] Macro(“SIP/102-00002e4c”, “hangupcall,”) in new stack[/CODE]

Just had this happen again (on an outgoing call again).

I see faxdetect=yes in sip_general_additional.conf
Where can I set this to faxdetect=no?

Found another post about this problem. faxdetect=no can be put into sip_general_custom.conf but then it breaks incoming fax detection as well.

Any way to disable faxdetect on just outgoing calls?

Also wondering about this. I had noticed it once before and thought it was a one off. But I’m getting a lot of dropped calls. I’d assume anyone using fax detect is getting dropped calls here and there but don’t realize it.

FreePBX is an awesome project but it’s tough when so many of the features break intermittently. Seems like you always have to make a trade off (which I suppose is life) bah :stuck_out_tongue:

This is not a FreePBX feature or bug. If something like this is happening it is a Asterisk problem but this post is about FreePBX 2.9 and Asterisk 1.6 which neither are supported anymore.

I’m reviving this thread as I just found that this was happening to me as well.

While this isn’t a FreePBX “bug,” it is a freepbx problem.

FreePBX has the faxdetect=yes parameter in sip_general_additional.conf. I can’t find a place in FreePBX to change this, other than to add “faxdetect=no” in my trunk settings or to add it to sip_general_custom.conf.

I’m not clear on how Asterisk will handle getting conflicting directives on this, however.

Further investigation reveals that faxdetect=yes is added to sip_general_additional.conf by Schmooze’s Fax Configuration module. If you disable the module, that line goes away.

You can also disable faxdetect manually by adding

faxdetect=no

to the area at the bottom of the Asterisk SIP Settings module, under “Other SIP Settings.”