EPM with DPMA


#1

Is there any reason changing the port on DPMA in EPM from 5060 to 5070 would cause it not to allow phone trying to provision to reach it?


(Lorne Gaetz) #2

I just tested with EPM 15.0.39.43. I changed the port in DPMA settings in EPM to 5070, submit and apply config and confirmed the change at the asterisk console and all worked as expected. I did a factory default of a D65 and when the prompt came up to enter the Digium Config Server I added the IP address with the new port and provisioning failed. If I just enter the IP address and leave the port field blank, then provisioning works.

Is that more or less what you’re seeing or are you provisioning differently?


#3

Thanks Lorne,

Currently running EPM 15.0.39.40

I’m provisioning via DHCP option 66. When DPMA in EPM was set to 5060 it worked no problem. I changed it to 5070 in DPMA Management, saved, and applied. Changed my DHCP Option 66 to reflect that change:

Sip:Proxy@pbx_public_ip:5070

Then I factory reset the phone and let it boot. I fails to get the initial settings and just stalls on contacting sip:proxy@ip of pbx:5060

IF however, I change my DHCP Option 66 back to 5060 without changing the settings in EPM DPMA then the phone WILL connect.

So it appears as if changes made to the port in DPMA Management are not being stored correctly perhaps??


#4

After the phone does it’s initial fetch of the config on port 5060 it reboots and tries to download the config from the VPN private address on Port 5070 and fails.

contacting sip:proxy@vpn_ip_address:5070;transport=udp


#5

Removed port from option 66 so it’s just sip:proxy@pbx_public_IP
DPMA in EPM set to port 5070
Setting > asterisk sip settings > PJSip > port to listen on = 5070
rebuilt phone configs in EPM Template

factory reset phone.
phone boots, gets option66 settings, fetches config from public IP port 5060 (I assume)
reboots, establishes VPN and fails on:

contacting sip:proxy@vpn_ip_address:5070;transport=udp

Question: where is the initial provisioning port set? why is it only working with 5060??


#6

TROUBLESHOOTING ATTEMPS separated by ++++++++

settings > sip settings > pjsip > port to listen on > 5070
submit, apply
CLI asterisk -rx ‘core restart when convenient’

EPM > DPMA Management > mDNS Discovery Port = 5070

EPM > digium Template > save and rebuild configs

DHPC Option 66 = sip:proxy@pbx_ip

factory reset phone

initial config fetched from sip:proxy@pbx_IP (takes a long time)

phone reboots

contacting sip:proxy@10.8.0.1:5070;transport=udp

Eventually fails here.

++++++++++++++

upgrade EPM to 15.0.39.43

EPM > Digium Template > save and rebuild configs

Reset phone

initial config fetched from sip:proxy@pbx_IP (takes a long time)

phone reboots

contacting sip:proxy@10.8.0.1:5070;transport=udp

Eventually fails here.

+++++++++++++++

settings > sip settings > pjsip > port to listen on = 5060
submit, apply

CLI asterisk -rx ‘core restart when convenient’

EPM > DPMA Management > mDNS Discovery Port = 5070

EPM > digium Template > save and rebuild configs

DHPC Option 66 = sip:proxy@pbx_ip

factory reset phone

initial config fetched from sip:proxy@pbx_IP (takes a long time)

phone reboots

contacting sip:proxy@10.8.0.1:5060;transport=udp

reconfigureing

Fetching config from sip:proxy@10.8.0.1:5060;transport=udp

phone appears to finishes booting correctly, show’s vpn status good, shows line but does not populate the soft keys and attempting to make phone calls results in fast busy

+++++++++++++++++++

Reboot PBX server, no config changes
factory reset phone
initial config fetched from sip:proxy@pbx_IP (takes a long time)

phone reboots

contacting sip:proxy@10.8.0.1:5060;transport=udp

reconfigureing

Fetching config from sip:proxy@10.8.0.1:5060;transport=udp

fails here

NOTE: All PJSIP trunks are now offline

++++++++++
asterisk cli: core restart now

EPM > extension mapping > change extension profile to non VPN template, set VPN Client to NONE

Save and rebuild Config(s)

factory reset phone
boots, contacting sip:proxy@public_ip
Reconfiguring
restart
fecting config from sip:proxy@public_IP:5060
finish configuring
NOTE: PJSIP trunks now online, test call to outside number worked
Line keys on phone do NOT populate with phone aps, blf or any settings.

+++++++
Rollback endpoint manager to 15.0.39.36
factory reset phone
phone boots, gets config, still no line keys populated


#7

after sitting for about 15 min, the phone now has the line keys populated


#8

change extension profile to vpn profile and re-configure phone

phone reboots, get’s vpn config and restarts.

fails on contacting sip:proxy@10.8.0.1:5060;transport=udp


#9

sent an email to Christian to open a ticket.


(system) closed #10

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.