EPM - SPA8000 using provisioning

I have a SPA8000 that works fine if I put in the values for Proxy,User ID, and Password for each line in the SPA8000 webpages. But I’d love for the SPA8000 to get it’s configuration from the EPM. I see the SPA8000.cfg, and XML that goes with it in the tftpboot directory. I have tried putting the below in the provisioning profile rule in the webpage of the SPA8000. Neither seems to work. FYI, is working for all of my Grandstream phones.

I did see the one liner and image here: http://wiki.freepbx.org/display/FCM/Supported+Devices-Cisco

So it appears that it should be that easy

I’ve also tried using the windows tftp client to contact the freepbx tftp server. No love.
So, does the SPA8000 not support http over an alternate port?
If I have to use tftp with it, what magic needs to be turned on for the default tftp server to start working? (I see it listening with lsof -i -n)
What else could I be missing?

What version of EPM are you using?

OK and do you tftp or http logs show its requesting the file?

Interesting. NOTHING for the device. I access the device just fine to get to it’s webpage. And I can make calls on the port that I configured manually. But the logs don’t show that device making request at all. It does show the grandstream phones accessing them in the httpd logs. Also, remember, I haven’t managed to get any device or client connected to the built in tftp server at all.

We had the same problem last year with a defective SPA8000 which is why I asked.

really, that it wouldn’t seek out a provision but worked in other ways? I’ll get on the horn with linksys.