EPM Selects Port 5070 for Obihai Line 2


(Mark Moore) #1

I have a clean installation of FreePBX v15.0.17.24 running EPM v15.0.39.40. All endpoints are using pj_sip FWIW.

I’m trying to auto provision an OBi202 with a handset on port 1 and a fax on port 2. The Obihai template is pretty lightweight, so there’s really not a lot to go wrong. It’s only one page of info, and nothing includes specifying the UDP port.

I setup the voice extension with Account 1 and the fax extension with Account 2.

Everything looks great, but when I auto provision the device, the SP2 Service Status on the OBi202 Status page shows it “Retyring Register” on port 5070.

Sure enough, when I grep /tftpboot/$MAC.xml, I can see that VoiceService.1.VoiceProfile.2.SIP.OutboundProxyPort is set to 5070 in the config file. (At least that confirms the auto provisioning is working. :grin:)

Worse, when I try to manually set the VoiceService.1.VoiceProfile.2.SIP.OutboundProxyPort value to 5060 in the Basefile Edit page in order to override the incorrect value, I get the following error when I click Apply “Save and Rebuild Config(s)”:

Undefined variable: value
File:/var/www/html/admin/modules/endpoint/functions.inc/functions_obihai.php:241

Does anyone have any ideas for a workaround? Does anyone know where to log a bug against the Obihai EPM module?


(Lorne Gaetz) #2

As a licensee of a paid commercial module, you are entitled to support. Open a ticket with your findings:
https://wiki.sangoma.com/display/FPAS/How+To+Open+A+Support+Ticket


#3

I have no idea about your actual problem, but very few applications require an outbound proxy. If the PBX and OBi are on the same LAN subnet, or if the OBi is talking to a cloud PBX through a normal NAT firewall, outbound proxy is not needed.

Assuming that ProxyServer and RegistrarServer are correctly set, making OutboundProxy blank (or not present) should work around the issue, because OutboundProxyPort will then be ignored.


(Mark Moore) #4

@Stewart1, I noticed that as well. But, the OBi202 apparently uses the VoiceService.1.VoiceProfile.2.SIP.OutboundProxyPort value to override the VoiceService.1.VoiceProfile.2.SIP.RegistrarServerPort. In the config file the RegistrarServerPort is set to 5060 but the OutboundProxyPort is set to 5070. The device factually uses the 5070 port setting for registration which I can confirm with sngrep.

Either way, there is no ability that I can find to make the OutboundProxy blank.


(Mark Moore) #5

As a temporary workaround, I run the following command:

grep -l 5070 /tftpboot/*.xml | xargs sudo sed -i.bak 's/5070/5060/'

This fixes the problem and allows the OBi202’s to correctly autoconfigure. But it will get stomped on the next time anyone rebuilds the Obihai template.


(Mark Moore) #6

Just an FYI @lgaetz, I opened a ticket on 3/3/2021 and the only response I’ve received so far is a question asking what kind of OBi202 we are using and what the extension number is. Nothing at all on a solution, and frankly it sounds ike they don’t even understand the issue. Not very satisfying. :unamused:


(system) closed #7

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.