EPM Problems provisioning Grandstream GXP2130

We have a GXP2130 and are not able to get it to provision at all with EPM. We’ve set the TFTP settings on the update settings to the server and rebooted. It reboots and we can see the provisioning requests on the server for settings and firmware, but then the phone does not actually get provisioned…

Anybody else have this issue or advice?

Make sure that EPM is up to date (current ver. is 13.0.100) and ensure your phone firmware is on the 1.0.7 branch.

Strange. I’m showing EPM most recent version as 13.0.98. Also, i can;t get the GXP 2130 to update the firmware. It’s all factory settings and when it reboots it simply does not get the firmware…

This is what it shows as teh version. I think CORE is the one to go by right?


I think the version you want in on “edge”. There was another message a couple of hours ago about the newest version and it’s not available on the standard list yet.

Endpoint 98 will be fine, but you need to upgrade the firmware.

For the life of me I can;t upgrade the firmware. It does not upgrade with the default factory settings. HTTP and firmware.grandstream.com does not work either. Tried pointing it to the Even downloaded the firmware and added to a local tftp server. Tried telling it to upgrade via the phone’s interface. Nothing.

Tried all of this to one phone taht has been working fine and to one straight out of the box (The one described in this thread). I must be missing something…

Even SSH’d in and told it to upgrade. Asks me yes/no I say yes and the connection to the device drops. But then nothing!

we ran into the same issue - we could not get it to update its firmware. we ended up manually provisioning the phone. silly, but there is a reason that i am not a big fan of grandstream phones.

Yep. Never again!

I never have any issues with the EPM and grandstream phones.

I also have standardized on the Grandstream GXP-2160. We have deployed approx 400 now and we love them. Amazing features for the money especially the huge full color display and 24 BLF buttons.

For those that it works on, is your pbx local? Ours is hosted remotely, so I’m guessing that has something to do with it…

Not sure what kind of DHCP server you’re using, but one thing we’ve had to do in some installs is disable the phone’s ability to auto config over DHCP (Allow DHCP 43 & 66 to override…). We disable those in these situations so the phone doesn’t take on any characteristics of the network, and strictly uses the URL we configure.

Also, we have seen issues with these phones in the past that if they partially download the firmware file and something interrupts it, it never tries again until the next version comes out. The fix we found for that is to factory default the phone.

So, in a real pinch, factory default the phone, disable those DHCP options, and place your URL in there and see if that helps.

As a side-note, we also don’t use TFTP - we use HTTP (if that helps at all).

Thanks. I just found a setting in my Peplink balance router. It appears that TFTP passthrough is disabled by default. I turned on the setting to provision and factory reset the phone. Provisioning seemed to start working. All the phone settings have been set. It also downloaded the new firmware from FreePBX.

I take it back. Sorry Grandstream, not your fault!

Just to be clear none of the gxp2160 that we have are local. Our server is hosted at CyberLynk. All 400 and some phones are remote and the largest install at one location as about 28. They are all provisioned by http on a custom port.