EPM not provisioning passwords correctly

EPM, Framework 12.0.47

Phone: 20 x Grandstream GXP2160

16 of these phones provisioned without a problem, the last 4 will not provision. In the log the only thing it says is wrong password.

I’ve gone to each extension and put in a “simple” password, factory reset the phones, the phones provision everything properly except for the account password. It will not register, the log says “Wrong Password”.

I contacted paid support and they kept referring to my setup where I specified the port to register with and said they have never seen that, but my argument is, it works for 16 phones, why not the last 4.

They had me create another template in EPM but I feel like that was just busy work. Point is no matter what phone I try to provision these extensions to it has the same error.

I’ve tried blowing away the extension and recreating it to no avail.

I’m open to suggestions at this point.

New user here. I saw similar behaviour with Cisco 7940 and 7941 phones. In my case, it seemed to be a password length issue. Simply changing the password didn’t work, but if I deleted the extension, then re-created the extension with a shorter password (16 characters worked for me), then I was able to provision 7940 and 7941 phones reliably.

1 Like

That was it exactly. Forgot to follow up. Did have top do amportal a MA restart but still worked.

Was more disappointed in support for not wanting to help solve this, it’s still a bug, but one that can be worked around.

A quick-and-dirty fix for this would be a global config option to define the length of the randomly-generated passwords. A better fix would be to define a maximum length per model of phone.