FreePBX | Register | Issues | Wiki | Portal | Support

EPM Grandstream GXP2140 AutoConfiguration

configuration
Tags: #<Tag:0x00007f74a9e789f0>

#1

Using FreePBX 14.05.25/Asterisk 13. We have mostly Digium phones and have Option 66 working. Digium phones configure properly. Using http with port 84.

Cannot get a Grandstream phone to configure. EPM found it in the network scan, we have a template and I believe we have the proper configuration files in our /tftpboot directory.

When the phone is started this is what I get in my httpd access_log:

10.20.17.133 - - [01/Feb/2019:12:00:24 -0600] “POST /zccgi/?userListRequest HTTP/1.1” 404 204 “-” “Grandstream Model HW GXP2140 SW 1.0.9.121 DevId 000b82e6xxxx”

This shows the correct IP address of the phone and its correct MAC address. No other requests are received. The phone comes up unconfigured.

If I put the IP address and port of the configuration server into the phone manually and hit “SEND” it replies immediately with “Download Failure.”

We have a similar FreePBX setup in another market with same versions etc. Configuration files appear similar, Option 66 is set similarly and that system has ONLY Grandstream phones. They configure themselves perfectly. We have compared all the settings we can think of that have to do with the process and everything is the same.

Does anybody have a clue what I’m doing wrong?

Thanks in advance,
Steve


(Itzik) #2

Can you go in your browser to the server address and view the configuration file?


#3

Yes. And I can grab it via tftp as well. I believe the phone defaults to TFTP but we have tried it both ways.