EPM disabled: Needs to be updated, but cannot

Doing the following command:

/var/lib/asterisk/bin/module_admin upgrade endpoint

Module endpoint successfully downloaded
Checking database tables…Done
Migrating tables as required…Done
Checking Settings and Defaults…Done

Fatal error: Call to undefined function endpoint_getbasefile() in /var/www/html/admin/modules/endpoint/functions.inc/functions_aastra.php on line 431
Whoops\Exception\ErrorException: Call to undefined function endpoint_getbasefile() in file /var/www/html/admin/modules/endpoint/functions.inc/functions_aastra.php on line 431
Stack trace:

  1. () /var/www/html/admin/modules/endpoint/functions.inc/functions_aastra.php:431

I have tried just removing the module, but it requires Phone Apps to be removed also.

/var/lib/asterisk/bin/module_admin uninstall restapps

The following error(s) occured:

  • Module not installed: cannot uninstall

In the web interface it is showing this on Phone Apps:

The Module Named “EndPoint Manager” is required, but yours is disabled because it needs to be upgraded. Please upgrade EndPoint Manager first, and then try again.

So, now what?


UPDATE: Seems I was able to get it removed, but cannot get the newer version to install.
The exact same error is appearing as before.

Check to ensure that Endpoint Manager is still within its support period, and if not renew with the instructions here. If that doesn’t help, open a support ticket under FreePBX Commercial modules.

I have not purchased it, but rather I am trying to use it with the Sangoma phones I have here. I guess support ticket it up.