EPM: Assign Extension to Template Only

Hello everyone.

We recently started using the Login Feature (Hot Desking) with the Sangoma phones, it works wonderful!

However, per the documentation, you can map an extension to just a template, and once you login from any phone it will pull the config from the template the extension is mapped.

I’m trying to do so, but I get an error “Please select model before proceeding with submission…”

And the same thing happens when I leave “Select Account” blank.

OK, so I added 101, set account 1, model s500. Mac = Blank.

But when I want to add a second extension with no MAC, I get the following error.

I’m on the latest version of EPM and all modules are updated.

Am I missing something? Or this is a bug?


Upgrade EPM to edge:

fwconsole ma upgrade endpoint --edge

I’m testing with endpoint and when I create an ext mapping entry without a MAC, I get this notice:


I’m on that same version of endpoint.

You get this when adding the first extension and it allows you to add the extension successfully, but when trying to add a second extension you get this pop-up, but also the one I mentioned which doesn’t allow mapping a second extension.

Were you able to map two extensions with no MACs?

With hot desking it only work with primary account 1 and would create a nightmare to work with other accounts and not something we would support for hot desking as we have no way once you logout since the Mac is removed from extension mapping to know which extensions were mapped to which accounts.

Tony I have no issue with setting Account1. But currently it’s requiring to set the phone model as well, which is bad for someone who has multiple type of phones.

And again, even you specify Account1 and you specify the phone model, you cannot map more than 1 phone to extension mapping as mentioned above.

We require phone model and on login we have no easy cosistant way of getting the model across all brands that we support hot desking on.

I get that, the wiki needs to be updated then.
But why can’t I map more than 1 extension? Can you confirm if this is a bug?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.