EPM and yealink phones [Solved]

Hi All,
I have yealink T46s phones and i have configure the template everytime i do a change on template and update phones it will reboot all of them which is not really a good think when computer hangs from it and interrupt workfllow.
The other issue is background image will not push to the phones from EPM but if i uploded directly to the phone it will work.

Thank you

You can prevent Yealink from rebooting by adding one line to the basefile, and then overriding the notify command.

First add this to your base file

sip.notify_reboot_enable = 0

Source: Provisioning Issue auto_provision.power_on = 1 required for Sip Notify or of course RTFM.

Second, you have to override FreePBX’s default SIP NOTIFY command for Yealink phones.
Add this to sip_notify_custom.conf

[reboot-yealink]
Event=>check-sync\;reboot=false

Thanks for posting this, it reminded me to submit an issue to add this feature to EPM.
https://issues.freepbx.org/browse/FREEPBX-18131

Thank you so much this worked like a charm thanks again…

You can omit the reboot=false.
It will only reboot if the setting you changed requires a reboot to take effect, such as vpn and a few others.

   [reboot-yealink] 
   Event=>check-sync\

Yes, I know that. The phone ignores anything except reboot=true when set to 0.
But I think it is better for clarity that this command is intentionally telling it to not reboot.
I made a more detailed post back in July elsewhere: https://mangolassi.it/topic/17626/how-to-add-ability-to-freepbx-to-reload-yealink-config-without-a-reboot

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.