EPM and Fanvil: unable to provision


I’m trying to provision a Fanvil V67 with EPM (commercial version) but Fanvil phone never gets it.
If I do a network scan in EPM it discovers well the phone in LAN (both FreePBX and phones are on same LAN).
I have created a Fanvil template that just has the destination and provisioning address setup with local IP of FreePBX and method setup at HTTP.
When I add the phone in an extension nothing happens on phone side. It’s never provisionned. I have rebooted phone but still the same.
What am I missing ?

Thanks a lot,


Have you configured the freepbx firewall to allow http provisioning? Also, have you configured the ports in Admin>System Admin>Port Management?

Discovering the phone is really done via a port scan process on the network, where the actual provisioning is done via the protocol you have set.

One other thing to check is to make sure that you have something that tells the phone to provision to your PBX. This could be a DHCP option, it could Fanvil’s redirection service, or it could be you logging into the phone and pointing the provisioning parameters to your PBX. Most often, I do this via DHCP options, but I can’t advise on Fanvil phones as I have not used them before.

1 Like

I have deactivated fw for now :wink: For port management I have modified nothing out of the standard http port redirected to 8080 and dedicated 80 at Let’s Encrypt for the SSL key.

oki I thought that using mac address in EPM would be enough to trigger provisioning.
For DHCP it’s not an option as I don’t have a dedicated network for phones :frowning:
Fanvil redirection service, you mean FDMCS service from them ? If so I didn’t find any documentation about how to use it properly.
In phone I have tried to setup manually provisioning server but doesn’t look to work. Fanvil is not really helpful too on that :frowning:



8080 is the standard for the Web Admin area. You’ll want to look under port management for HTTP Provisioning. The default is 84 for HTTP and 1443 for HTTPS it looks like. You’ll want to make sure you know what port this os. If you are doing this over HTTP you would want to make sure the redirect is turned off here.

Next you’ll want to check the Provisioning Protocols under the System Admin module to see if you have HTTP auth turned on here. Up to you whether.you do or not.

Finally, you’ll need to set the Static Provisioning on the phone so it should be something like:
Set the protocol type to HTTP and then the update mode to Update after Restart. After you have done this, go to the restart tab and restart the phone. If you have your ports configured properly, everything should download just fine.

You may wish to reset your phone to factory defaults prior to setting the provisioning settings in the phone. Most phone vendors will not override any settings you have already made in the phone when it pulls the configuration from the PBX. (IE: if you set a line key via the Web GUI on the phone, the auto provision will not effect that key until the phone has been factory reset and the phone reprovisioned.)

I confirm provisioning port is well setup at 84 (I don’t have an HTTPS provisioning port !)

nothing related at http auth there :frowning:

Still the same after these changes :frowning: I think I’ll go with manual provisioning as automatic one doesn’t look to work at all in my situation :frowning:
Will let you know how it goes with manual provisioning, Thanks


If you don’t use a redirection server, then “something” has to “tell” the phone where to look for its configuration file. Normally, you can do that by configuring option 66 on your DHCP server.

Please confirm you can view the configuration file by opening in your browser. (replace MAC with the phone’s MAC address)

I confirm I get well the provisioning profile when I try to access the url you indicated with mac address of one of the phone I try to auto-provision.
I tried to do manual provisioning on phone by filling myself the SIP parameters but it doesn’t connect too so I guess there is an other problem somewhere. Here are settings I used in phone:

I tried with extension and also user password but same, it doesn’t connect and timeout. If I do a telnet on server IP and port I get well a connection.
Firewall is deactivated so it’s not the problem !

Possibly the IP is banned by fail2ban.

Please enable PJSIP logging and post a register attempt via pastebin

I have checked the /var/log/fail2ban file that is empty so it looks like it’s not fail2ban that blocks !

I have activated it in asterisk cli but nothing logs when I restart one of the phones. The only thing that shows up there is the sip registration of my trunks but nothing about phones :frowning:
I’m totally lost there why it doesn’t even try to register on freePBX, phones are in same lan than freepbx and I have no filter, nothing in my LAN that could prevent phone to reach FreePBX :confused:
I also tried to ping from FreePBX terminal the phones and it pings fine !

I have tried also to register with a softphone (Wave from Grandstream) but same, it’s unable to connect at FreePBX and nothing in pjsip logs :frowning:

Found out the issue (I’m stupid :frowning:). I had followed a tutorial for initial setup of FreePBX that advised to change the default port of SIP. Later I realised it was a bad idea and putted it back at 5060 but in one of fields of asterisk SIP settings I had typed 5860 instead of 5060.
As soon as I changed the value and putted the proper one, phones have gone online :ok_hand:

Thanks again for your help and sorry for the pain :see_no_evil:


I found an issue which has been fixed a few months ago about the phone book.
Nown, It is provisionned correctly as well.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.