Entering in Freepbx as non-admin user

Hi guys,

sorry for my poor english, I’m italian :slight_smile:

I have to install a trixbox server but my client wants to have access to the Freepbx interface for some common administrative tasks, such as managing extensions, voicemail and so on.

For this reason, I need to know if there’s a way to create a new freepbx user with non-root privileges, so that my client cannot modify important settings (trunks, etc.).

The perfect solution would be to completly hide some freepbx sections, (trunks section and others).

Thank you - kind regards


There is a database authentication mode that is designed for doing exactly this. Click the “Administrators” link in FreePBX.

Hi all,

after having set the “authtype” field to “database” in /etc/amportal.conf on my trixbox server, I added a user with the Freepbx Administration module without root privileges (permission to manage only extensions), in order to have a more elastic administration process. Apparently all went fine, but now I can’t access to freepbx (pbx>pbx settings)! In fact, when I click on the pbx settings link, the page becomes blank and I see Firefox that shows always the “Connected to 10.1.1.x” (trixbox ip) written in the down bar…

How can I fix this?

Thank you - Daniele

It is a TB thing, they have a second http.conf file you will need to find and edit out the folder blocks.

go find my post on it at TB forums

Thanks Bubba, but I couldn’t find a post written by you where there are instructions about editing a second http.conf. Do you remember the thread name?

I tried to search with “Administrators Module” and “AUTHTYPE not set to ‘database’” as keys words.

Thank you very much!

You posted a link to the docs here which had something about the TB http.conf file did you edit it and restart httpd (httpd -k restart)

then you edit the the amportal.conf to set none to db and do a amportal restart you should then be able to login as admin/ password
and change the admin password

You described exactly the procedure I followed, the problem is that it didn’t work for me…after these steps, if I click on the freepbx link, I can enter without doing any log-in…any ideas?

I had the same problem. I resolved it by setting


in /etc/amportal.conf