Endpoint Setup has Vanished


#1

Endpoint configurations have vanished. As a result, restored an earlier disk image which should have had endpoint settings displayed and did not. Tried earlier backup but it did not normalize Endpoint setup. Version 15.0.16.56. Endpoint 15.0.24.34.


(TheWebMachine Networks (Sangoma Software Development Partner)) #2

You have to be careful with data for Commercial (paid) Modules. To restore data to such a module, you must have a valid activation and Deployment ID on the system with a valid license for the module in question.

This is especially true for the Endpoint Manager. It simply won’t restore its data if it doesn’t have a valid license installed.

Also note that restoring a snapshot or disk image to a real or virtual machine with a different UUID will invalidate the activation from the system and it will need to be re-applied to the system. You can use the Zend Hardware Reset via the Sangoma Portal > My Products > PBX > List if you have lost access to the old machine. This will allow you to move the Deployment ID to the new machine and then restore your EndPoint Manager data properly. I’m not saying that is the case here, but wanted to throw it out there in case it is.

Also, you should confirm that EndPoint didn’t get disabled…or, more specifically, that your EndPoint module isn’t being held up/disabled by a Rest Apps update dependency. If you see Rest Apps complaining that it needs EndPoint updated so it can update, and you’re out of your maintenance period on EndPoint, you can disable Rest Apps module so Endpoint can be re-enabled without interference from the Rest Apps module dependency…but you really should pay the maintenance/update fee and ensure all your modules are up-to-date if this is, in fact, the case.

I hope one of those paths leads to resolution. If you’re seeing any error messages or other information, post that here (or pastebin) we can all take a closer look. :blush:


#3

EP functionality just disappeared. I am not sure how recently as I don’t look at it frequently.
Following it disappearing, I did a disk copy backup and its content was also missing.

I have one Sangoma S500 and a handful of Aastra phones. Hardly a demanding array of phones requiring management. I have long thought that EP should somehow be made very available for small installations. A PBX kind of needs phones connected or it is not all that useful.

Capture1


(Jared Busch) #4

If you had any idea how everything worked, you would realize that this is impossible to audit. That is why it does not exist.


#5

Can you explain what you mean?


(Jared Busch) #6

Every phone on the planet uses a formatted text file to pull their configuration.

All you would have to do is

  1. configure EPM to generate a config file
  2. copy it to another folder
  3. delete from EPM
  4. go back to step one until all your extensions are created.
  5. copy all the files back to /tftboot

And because EPM has fwconsole commands, I could script the entire process.


#7

Thanks. Interesting and possibly useful but doesn’t answer why my EP has recently stopped functioning.


(Jared Busch) #8

Another user already answered you for that.


#9

Is Rest Apps actually called “Phone Apps”? In that case the module is not loaded. No error messages. EP seems to be able to be used but lost settings.

Was working fine after upgrading to V15.


#10

As we were assured that previously licensed versions of EP would continue to work. These
statements bring up some important problems and questions. Especially considering policies with re-licensing EP requiring paying for the entire time since the last subscription.

On the Sangoma site:
Note : Sangoma IP phones designed for FreePBX include a lifetime EPM license and do not require any additional purchase to use the FreePBX EndPoint Manager.


#11

Little relevant help for this post. Mostly due to offering answers without asking any questions?
Jared offered an interesting suggestion which could be useful at some point, thanks. On the other hand no help pinning down the actual problem, just conjectures. Need better… If this offends you then you are missing the point of my feedback. (>:}


#12

On the Sangoma site for their phones:

Note : Sangoma IP phones designed for FreePBX include a lifetime EPM license and do not require any additional purchase to use the FreePBX EndPoint Manager.

My EP module is active and functions and I assume can be rebuilt but all my prior settings are missing so the question is what happened.


(system) closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.