FreePBX | Register | Issues | Wiki | Portal | Support

Endpoint not creating vpn tar file for yealink phones anymore


#1

FreePBX 14.0.13.4
PBX Firmware:12.7.4-1803-1.sng7
PBX Service Pack:1.0.0.0
EndPoint Manager 14.0.5 Stable
System Admin14.0.33 Stable

In the past I was able to select the extension for the vpn file in endpoint manager and it would create the mac-vpn.tar file in the /tftpboot folder. Now it lets me select the VPN user account, sets the VPN enabled flag in the config for the extension to 1 but leaves the openvpn.url as blank and no tar file is created.

I have tried deleting all vpn profiles, disabling the vpn server and resetting the certs using another posts suggestions but it gets back to the same result.
rm -rf /etc/openvpn/clients/*
rm -rf /etc/openvpn/client/*
rm -rf /etc/openvpn/ccd/*
rm -rf /etc/openvpn/sysadmin_*
rm -rf /etc/openvpn/ipp.txt
/etc/openvpn/easyrsa3/easyrsa init-pki

Can someone point me in the right direction.

thanks,
Cliff


#2

Just bumping this back up to the top. I have uninstalled and reinstalled endpoint manager now as well with the same result.

thank you,
Cliff


#3

After a little more research I determined that for some reason the ca certificates weren’t made.
The resolution was to move openssl-1.0.cnf from the easyrsa3 folder to the openssl folder and rerun /etc/openvpn/easyrsa3/easyrsa init-pki

after that I was able to get the openvpn server started and endpoint was then able to create the tar files.