Endpoint Manger and Cisco 7941G phones

I installed the latest FreePBX Distro and have been attempting to configure the system. I ran into a problem with the Cisco 7841G phones. I was using the OSS EPM. I convereted the phones to sip and setup the TFTP server. The phones were download the SEP and firmware files correctly but the phones were not registering so I thought maybe the switch to the commercial EPM would help solve the problem. However, the documentation for the commercial EPM is lacking!

First, The available firmware for Cisco shows to be 0.00, 1.00, 1.01, 1.02 and 1.03. Those numbers mean nothing to me. I have multiple versions of Cisco firmware that I downloaded directly from Cisco, such as SIP41.9-3-1SR4-1S and etc.

Anyone know how to get those versions up and running in EPM?

P.S. All the versions included with EPM are for the SPA series of phones… nothing for the 79XX series

Are you speaking of the 7941 series phones?

My team worked closely with Schmooze in getting this to work. We now have literally 1000’s of phones provisioned. Where are you running into trouble?

The Cisco firmware is not open source, you have to have a contract with Cisco to use it.

With that in mind you also don’t have to let the EPM manage it. The key is making sure the version you are running (and that is available to he phone from tftp) is correctly set in the basefiles.

Yes, 7841 was a mistype. I have multiple 7941G and a couple of 7965G phones.

I am having multiple issues. Network Scan does only finds one phone. I am sure the problem has to do with the first 6 digits of these phones not being included in the MAC discovery table but I haven’t found where to add the first 6 digits which are registered to Cisco. I know I did this with the OSD EPM but can’t find it in EPM.

The other issue, so far, is the BaseFile Edit does not seem to be working as there are not BaseFile Templates listed. The only file listed is the one I created for Cisco. When I click on it the only thing that happens is three buttons, SPA, Enterprise, Ent-Dialplain appear but nothing happens when I click them.

Under Firmware Management I would like to add the Cisco firmwares that I have purchased, but I see no way to do that. The only firmwares that are created are all for SPA devices. Can I just add the Cisco ZIP files to /tftpboot/firwaredownloads/ ?

No big deal, but why are 13 y000000000xx.cfg blank files created in /tftpboot/ ?

What is legacy_sip.cfg for?

Why is aastra.cfg created when I am not selecting aastra.cfg phones?


As stated in another thread. We do not scan for devices that are listed as un-supported by us. Such as the Cisco 79XX series.

Basefile should like you edit configs for your template. Clicking on those Enterprise should bring up lots of options. I bet your resolution is to small so you need to scroll down on the page for them to show up.

Review the userguide at wiki.freepbx.org under Commercial Modules EPM it talks about uploading your own firmware into the 0.00 slot in /tftpboot/cisco/. Slot 0.00 is for your own custom firmware.

Those are all files for other brands that get placed in tftpboot at install time since you are licensed for all brands with EPM>

See my post about MACs in the other thread.

Not a resolution problem, two monitors with 1920x1080. However I tried FoxFire and guess what, when I click on the icons Enterprise and Ent-Dialplan they do come up.

I have read every page of the wiki about Commercial Modules EPM and find nothing that tells about uploading a firmware. Maybe my 66 year old eyes are getting tired. I know it means nothing, but I have been programming computers since 1978 and the Asterisk configuration has given me more problems than anything I have ever worked with. I will admit that I have stayed away from Linux all these years and so I am having to learn something new with Linux, Asterisk, FreePBX and Endpoint :-).

Thanks for taking the time to try and help this old dog! I will get this system working one way or another!

I finally found the problem. FreePBX Extensions was creating a 16 octet password, which was not being accepted. I manually put in a password, currently 9 digits, and all the 7941g phones booted up and are not registered. Still have not got the 7965g phones running yet.

I switched back to OSS EPM, now I will back up my system and reinstall Commercial EPM and see if I can make it work.