Endpoint Manager - Yealink T46G provisioning - PJSIP no go

Is anyone out there using commercial Endpoint Manager (13.0.2) to provision Yealink T46G phones that have their extension set up as PJSIP?

Doesn’t seem to work here, Phone registration status always shows as registering. The correct parameters appear to be in the account settings, even SIP port 5061 for PJSIP. A factory reset of the phone and manually setting the account parameters will result in a registered phone.

Phone provisions correctly when extension is set to CHANSIP,

Silly simple question but are you sure your pjsip port is 5061? Did you manually swap them? Because the default is pjsip 5060 and chan_sip 5061.
My guess would be that in both instances it is trying to register to 5061.

I noticed that with my yealinks and pjsip they don’t want to register right away. I had to be patient.


Yes, it was an upgrade from FreePbx 12 and all extensions were CHANSIP.
I enabled PJSIP and it states that it is indeed on port 5061. Like I mentioned, when manually entering info into phone it registers, but when trying to provision from endpoint manager it just sates it’s status as registering, so EPM must be doing something wrong, even though the info looks correct in the phone GUI.

So I take it EPM is provisioning your phones correctly and they are registering, just taking a while.

Are the extensions setup as Chan_SIP or PJSIP?

Unless EPM isn’t correctly setting some odd setting burried way in the config I can’t imagine why it wouldn’t provision. Have you checked that the password is correct in the file that it is provisioning from? That’s the only parameter that you can’t confirm in the phone gui.
I would try hand making a file with the template off of the yealinks website with just your login credentials and see if provisioning from that file works.

And no, my machine with EPM is FreePBX 12 with Asterisk 11.

I ran into this same problem. The issue is that the default config in the Yealink T46G has port 5061 assigned to TLS. So, when provisioning through EPM, TLS is not changed to another port. The T46G doesn’t resolve this conflict and can never register. To fix it, you have 2 options:

  • In the Phone Config GUI, (the IP address of your phone), in the SIP settings, change the TLS port to anything other than 5060 or 5061. For example, you could use 5065.

  • In the Asterisk PJSIP settings in FreePBX, change the PJSIP port to something other than 5061 (if that is what it currently is). For example, try assigning port 5065 to PJSIP.

If you use option 2, rebuild the device configs, then reboot the phone to download the new config from EPM. Your phone should register fine after that. Frankly, option 2 is probably the better choice. Then, you won’t have to log in to every phone to adjust the TLS port.

Just for supplemental info, its not just the T46Gs, its most of their phones. I run a variety of models. Switching the PJSIP port was the quickest method for me, although editing the basefile for the yealinks would also work.

thanks Bullfrog,

I swapped things around so that 5060 was for PJSIP and 5061 for CHANSIP. Yealink endpoints are connecting but I still have to use CHANSIP to connect to my Vitelity trunk as I can’t seem to make the trunk connect via PJSIP