EndPoint Manager will not Reboot My Phones

I have just finished installing my first FreePBX box and everything seems to be working fine, except for one thing.

In the EndPoint Manager I cannot reboot my phones. I have Polycom 331 phones. The EndPoint Manager recognizes them and as long as I reboot them manually they pick up the configurations from the server no problem. All calling works fine as well.

If I login to the asterisk CLI and issue the command

sip notify polycom-check-cfg

that works with no problems. I just can’t get the Web interface to reboot my phones. I have tried deleting the phones and re-adding them. I have removed the EndPoint Module all together and re-added it. I have tried all the various buttons on the EndPoint Configuration Manager page with no luck.

Can someone please help. :slight_smile:

I know that when I wrote the portion of EPM for the Cisco ATA’s, they only had a check-cfg sip notify as well, but once you sent the check-cfg, they would pickup the changes on the fly, no reboot needed. So double check to make sure the phones aren’t actually picking up your changes, without the need for the reboot.


this sounds kind of “janky”… but if you are using PoE… then just flip the switch on/off?

not all PoE switches can be remotely rebooted…my Cisco catalyst 3550 i have at home for lab purposes does allow that, but as an alternative there are ethernet based remote reboot devices. I would do some work on the epm module if i had a polycom for testing, but unfortunately i do not :frowning:


Look under advanced settings under Endpoint. Where does it say the asterisk location is.

when logged in as the asterisk user can you run asterisk from said location above?