Endpoint Manager - Phones Won't Remote Reboot

Hey everyone, I would appreciate any help that anyone has to offer with an issue that I’m having. First the hardware/software setup:

Endpoint Manager:
Phones: Cisco SPA 303 w/ Firmware 7.5.2b

I currently have my extensions built and phones configured in Endpoint Manager. The phones pull down their configuration properly, pull the firmware upgrade and apply it successfully, reboot, and everything is great on that front.

The issue that I’m having is that the phones won’t respond to a “Reboot” command from the Endpoint Manager. If I change the profile that a phone is assigned I can see the file update in /tftpboot. If I pull the power on a phone, it will pull its updated configuration file and apply it, but, since I’m going to be managing this phone system remotely, I would love to have the ability to remotely reboot the SPA 303s.

I have tried sending the phones a manual “sip notify cisco-check-cfg” as well as an “sip notify spa-reboot” from the Asterisk CLI. The phones just sit there.

I have worked with the Cisco SPA 504G in the past and didn’t have this problem. I know the 504 and the 303 run the same firmware so I’m at a bit of a loss.

Any help is appreciated.

EDIT “Resync on SIP” is enabled in the profile and I can confirm it is enabled on the phone through the web interface.