Endpoint Manager not pulling in Config to phone


(Icd Mike) #1

I have several S500 phones that, after setting them up in Endpoint Manager, they do not pull in their config after a reboot and/or via the “Force Phone to check Config” button.

Is there a way to force the config into phones?

Mike


(Lorne Gaetz) #2

The phones must be configured with the correct provisioning address, either by using the zero touch feature in the portal, with DHCP option 66 or by manually configuring the phone with the url.


(Icd Mike) #3

Yes, they are configured using zero touch in the portal, but I see a poll count of 0 and they aren’t pulling in an IP address from my network.


(Lorne Gaetz) #4

This is step 1. A phone without a LAN connection is not going to provision.


(Icd Mike) #5

I think my response caused you to misunderstand. The phones all had a LAN connection and pulled in necessary updates and connected to the portal successfully. It is now, via viewing in the portal, that I do not see an IP address listed in the “Last Poll From” column.

Thus, they aren’t connecting to the portal to get the redirect info and then aren’t connecting to the PBX to get a config.

Mike


#6

Choose on of the phones and determine it’s IP address. Then run a packet sniffer on the PBX (tcpdump, ngrep) monitoring any traffic from that host. Reboot the phone and see what traffic is coming from the phone - if any.

If no traffic, implies phone not getting provisioning info from DHCP (or other method depending on which you used).


(Icd Mike) #7

Yes, I am getting network data too and from the phone and PBX. Just tested with tcpdump. Yet, no config.


#8

What is the “network data” you are seeing?
How are the phones supposed to be getting the config:

  • how are they configured to get the provisioning info (dhcp, manual config, zero touch)
  • what protocols are being used to get the config files (https, ftp, tftp, etc)

(Icd Mike) #9

They should be getting the config with Zero touch using Sangoma Redirection and not Option 66. Using http on port 83.

I must be missing something, as all my older configured phones seem fine and the Sangoma Portal sees them as having polled. Just this newer batch doesn’t seem to connect back to the portal, though it does connect to Sangoma to check firmware, etc.

Mike


(Icd Mike) #10

I think I’ve uncovered something. The phones are connecting to and trying to pull in a config from what appears to be a Mitel server at another internal address. I suspect another department has setup an Option 66 that points to the Mitel server. (not sure if that makes sense, as I’m not very familiar with Option 66).

If that is the case, is there a way to bypass that and just configure the phones to connect directly to our FreePBX server?

Mike


#11

If the DHCP setting is being used, you would need to get whoever controls that to change it for you. If your phones are on a different network, they should be able to make a separate configuration for your network. If on the same network, then they have to make a separate one for each of your phone’s mac address.
Also, perhaps your phone has an option you can set manually to ignore dhcp? If so, could do on one phone to verify that this DHCP option is the source of your issue.


(Lorne Gaetz) #12

Yes, you can manually input a prov string in the phone gui, and there is a checkbox to ignore the option 66.


(system) closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.