FreePBX | Register | Issues | Wiki | Portal | Support

Endpoint Manager changing config server to include tftp prefix

configuration
freepbx
Tags: #<Tag:0x00007fcd2180a890> #<Tag:0x00007fcd2180a700>

(Matthew Jensen) #1

I’m trying to set up the endpoint manager to configure our gxp 2170s. I haven’t been able to get option 66 working, so I’ve had to go into each phone to configure the config server as the freepbx server. This works fine. I type in the ip and it grabs the config file. But after that, I’m not able to give it any more configs. The config changes the server address to include the tftp://, and as far as I can tell, this is preventing it from grabbing any more updates. Is there a way to not include this prefix in the config? I know on another system I manage, epm doesn’t seem to add that prefix, so maybe I can fix this by downgrading epm. What are your thoughts?


(Lorne Gaetz) #2
fwconsole ma --edge upgrade endpoint

https://issues.freepbx.org/browse/FREEPBX-17257


(Matthew Jensen) #3

It appears to be getting stuck at: “Checking settings and defaults.” And now the module is disabled.

Update:

It seems to finally have updated to 14.0.2.58, but I’m still having a problem with the config urls.

New Update:

Everything seems to be working now. Sorry for that. Except now I have another similar problem. If I try to use the native background image option in the epm, It doesn’t fill the download field properly. It only puts the path of the file, not the protocol or server address. This is left out: tftp://server-address. I added it manually in the basefile, and it works. So I’m not stuck right now, but it could probably use an update to fix that. Again, I’m testing on a gxp2170 with the epm module 14.0.2.58