End Point Manager - Firmware Not Saving in Slot 1, Slot 2

I installed the Free PBX using the Distro.
I got the Paid Version of End Point Manager. But running into Couple issues.

a.) Cisco SPA 504G Phones keeps Upgrading Firmware every few minutes. Its Random. Sometime in 30 Minutes, Sometimes in couple hours.

  • I thought may be I need to pick an older or newer firmware but in the dropdown (Template Creator) - only option shows for firmware is “recommended”.

I went into the “firmware management” and tried dragging the older firmware in Slot 1 and Slot 2. I can move but as soon as I click Submit - Firmware Disappears from Slot 1 and Slot 2. And offcourse - firmware do not show in the Drop Down in the Template Creation in the End Point Manager.

b.) Another Cisco SPA 962 – BLF Buttons giving me flashing orange.

c.) Time is showing different on each phone.

Please note that I am running the newest version of FREE PBX with Asterisk 12.

Just a quick comment. You are using the Alpha distribution. I would not do that for production. Should run stable.

Hi hopeitworks,

I am having the same problem with the SPA504G, Guess it is a version issue! What version are you running on the phone? I am about to try and manually update mine, and see if that fixes it! As for your other issues, I found with my SPA942s that the BLFs worked better if I edited the basefile, hopefully the 962 isn’t much different. I also found you could use the full functionality that way!

As for time, are you sure they can all access the NTP server?

Oh and SkykingOH, normally I find your posts very useful, and helpful, that one… was not.