Enabling https for the FreePBX administration page

I have recently installed AsteriskNow and upgraded to 2.8. Everything is working beautifully. I was wondering if anyone could tell me how one would go about enabling https access for the FreePBX administration pages. It occurs to me that if you are administering the pbx over the internet all extensions and secrets would be transmitted in clear text, thus allowing someone (sniffing packets) to connect to your PBX extensions or the Admin console itself.

Thank you for your help.


Rather than have ports open towards the Internet I prefer to set up my firewall router so I can open an encrypted VPN tunnel to it, then I can access the PBX and anything else behind the router securely.

Thanks billsimon! I’m a bit new to the linux/Asterisk world and your suggestion (plus including the actual commands) worked flawlessly.

– Changed the router settings to only allow SSL and went right in via https!

Totally agree with you. I would prefer that too, but the router for this installation does not support vpns. Thank you for the suggestion though.

CentOS, right?

‘yum install mod_ssl’ to get the https module and config for Apache.

‘service httpd restart’ to activate it.

By default the SSL site is the same as the non-SSL site and uses a self-signed certificate.