Enabling FXS ports 3, 4 on a DAHDI card


(Michael Coulton) #1

Hello

How do I enable / activate ports 3/4 on a DAHDI card. I believe this can be done via CLI, however the only command that I’m aware of is setup-sangoma followed by a reboot. That didn’t help.

Thanks in advance for any help that can be provided.


#2

You need to re-configure the card, either with the setup scripts or manually editing the conf files.


(Michael Coulton) #3

Thanks

What command do I use to access the set up scripts and what config file am I editing?


#4

Is this a Sangoma or digium card?


(Michael Coulton) #5

Hello
It’s a Sangoma card.


#6

you should be able to use the command-line script wancfg_dahdi, or if you prefer, install the dahdi module and work it through the GUI


(Michael Coulton) #7

Thanks
I’ve re-configured the card using the wancfg_dahdi command and done a reboot, however the FXS ports won’t activate. Any other idea’s?

Thanks for the help.


#8

You would have to provide a lot more info, like card model, contents of DAHDI config files and so on.


(Michael Coulton) #9

Hello
I’m running a Sangoma A200 with a 2 port FXO & 2 port FXS cards piggy backed on top. How can I re-activate the FXS ports and what would cause them to fail?

Thanks in advance for any help that can be provided.


#10

Are you using the DAHDI module to configure it? Can you uninstall it temporarily an re-run wancfg_dahdi?


(Michael Coulton) #11

I will try this later today.

Just to be clear, I’ve attached a screen shot of the module that needs to be disabled. Is this correct:


#12

Yes that is the one. But if I were you, I would uninstall it, so all its files are removed and you can start from a fresh DAHDI configuration.


(Michael Coulton) #13

Hi
Thanks for the help. I un-installed the “DAHDI config” module and used the command line to “wancfg_dahdi” plus rebooted the system with no effect. I then re-installed “DAHDI config” and used the GUI to complete the configuration plus a system reboot. Now I’m back to only the FXO ports being enabled and not the FXS. Any other suggestions?


#14

If wancfg_dahdi is not activating the ports, there’s the chance that the port module is not correctly settled on the card.


(Michael Coulton) #15

Okay. I will look into trying to re-seat the module on the card. It’ll be a couple of days before I get to it. Thanks again for your help.


(system) closed #16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.