Enable WebRTC in PJSIP ext


(Nick) #1

Hi,

I’ve been working on PJSIP (asterisk).

Audio and video call is working fine when all the exts were coming from static file i.e pjsip.conf file. Now I have created those in Freepbx but Don’t know how to enable “webrtc=yes” setting in Freepbx.

I have gone through all the settings in Freepbx panel but did not found that settings.


(Lorne Gaetz) #2

The option is in advanced settings for the pjsip extension, but there was a recent thread and ticket noting that it’s currently broken: WebRTC Default Toggle doesn't work


(Nick) #3

Thank you for your reply.

Yes, But that toggled is not working as raised by some other users and still that problem is not solve by Freepbx.

Is there any other way to put / enable that option (webrtc=yes) via freepbx.


(Lorne Gaetz) #4

Work around added to above thread. I thought it was already there.


(United States) #5

I had a similar situation except I recently converted from CHAN_SIP to CHAN_PJSIP. Since the WebRTC ie 99### extensions were all setup from when it was CHAN_SIP the solution to my problem was different.

I used the GUI and Edited the User Ext in the Advanced Config I changed he option Enable WebRTC defaults to YES and this removed the 99### extension from the pjsip.endpont.conf so only the ### extention was listed and the WEBRTC client started working.

I think this was related to my converted from SIP to PJSIP and then I used the console utility to update all the clients to PJSIP. converting sip to pjsip wiki post I am going to make a recommendation that the tool also set the Enable WebRTC defaults to YES as part of the config change.

Having the 2nd Ext is only necessary when using CHAN_SIP because it can’t have more then one device registered to the same extension like CHAN_PJSIP can.


(Amardeep Kashyap) #6

PJSIP with all enabled option for WEBRTC shows only wrong password.
image


image

when trying to register on sipML5 its not working on asterisk end


even i put the password as 12345 same error.
how to fix this.
i think if this will work than also pjsip can be work as webrtc


#7

Make sure that WebRTC is using chan_pjsip as I bet it is using chan_sip.

Configure FreePBX extensions to use WebRTC and PJSIP only:
a) Settings -> Advanced Settings -> Display Read Only Settings -> Yes
Settings -> Advanced Settings -> Override Readonly Settings -> Yes, Submit
Settings -> Advanced Settings -> Force WebSocket Mode -> PJSIP, Submit
b) Applications -> Extensions -> Edit Extension
Advanced -> Enable AVPF -> Yes
Advanced -> Enable ICE Support -> Yes
Advanced -> Enable rtcp Mux -> Yes
Advanced -> Enable WebRTC defaults -> Yes
Advanced -> Media Encryption -> DTLS-SRTP
Advanced -> Enable DTLS -> Yes
Advanced -> Use Certificate -> LetsEncrypt generated certificate
Advanced -> DTLS Verify - Fingerprint, Submit
Apply Config


(Amardeep Kashyap) #8




image

Now on this configuration its working.
I need to reinstall same server twice.

Thanks for your support


(system) closed #9

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.