Email Setup > SASL Config Problems

I am having trouble with Email Setup on both of my FreePBX servers. First let me state that everything was working well for quite some time, then I made a small change, and now I am unable to return to or find a new configuration that works (for this email .

Some background on my settings:
We use Google Apps, where I have configured an SMTP relay that does not require authentication from designated IP addresses, which includes the external IP addresses of my FreePBXes. This works from my other non-FreePBX servers and previously worked for FreePBX, but does not now.

SMTP Server: Use External SMTP Server
My Hostname / My Origin: [server].[domain]
My Domain: [set to my domain]
Provider: Other
SMTP Server: smtp-relay.gmail.com:587
Use Auth: No Authentication
Use TLS: Use TLS
SASL Security Options: Disable Security

I have tried a variety of configurations, and have not been able to get back to one that works.

I note that in the debug log, I receive a warning, “SASL authentication failure: All-whitespace username.” If I switch to “Use Authentication” and enter something for the values, submit the change, switch back to “No Authentication,” and submit the change again, I do not receive the warning.

I also note the following in the log:
(SASL authentication failed; server smtp-relay.gmail.com[74.125.28.28] said: 535-5.7.8 Username and Password not accepted. Learn more at?535 5.7.8 https://support.google.com/mail/?p=BadCredentials f187sm3506630itc.1 - gsmtp)

This leads me to believe that even though I have authentication turned off, it is still trying to use authentication. Am I missing something here? Has anyone else had a similar issue? Because it was working before making changes and submitting, it leads me to believe that the issue is related to a change in how the System Admin module is generating the config.

Any help is appreciated.

I’ve noticed this too.

If you go into /etc/postfix/main.cf

Look at the bottom and even if you disable all of the AUTH, TLS, and SASL the config will still remain in the main.cf file.

As a workaround for me, I just manually remove them from main.cf and restart postfix. Just dont make any changes via the GUI and it will work fine. :smile:

1 Like

Thanks. I confirmed that making a single change in main.cf has it working again.

Even though the GUI is set to “Use Auth: No Authentication,” main.cf had:
smtp_sasl_auth_enable = yes

Changed to:
smtp_sasl_auth_enable = no

And I just received a slew of my test emails.

I will open a ticket.

I can’t find a ticket for this one. What ticket number?

Edit: I found another one referencing this – http://issues.freepbx.org/browse/FREEPBX-12681 so I’m working against that one.

Sorry, before I could submit the ticket I got pulled away. I see you found a ticket, but for reference, the one that I just opened is: http://issues.freepbx.org/browse/FREEPBX-13325. Maybe now a duplicate.